summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorEric Schulte2020-04-29 18:25:49 -0400
committerEric Schulte2020-04-29 18:25:56 -0400
commita02c516beeb2032afcf7e6c3185ffec7bfb3e841 (patch)
tree6e55c47ee9ca3bc7e3ccacc3bf5fad4bd3c6ff28 /PKGBUILD
parent10b8cd252d067f680e961b43854b488cc5440c3b (diff)
downloadaur-a02c516beeb2032afcf7e6c3185ffec7bfb3e841.tar.gz
Update dependencies, don't force clang build
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD11
1 files changed, 4 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index e0ebe992ba28..f6860c58e349 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,17 +2,14 @@
# Maintainer: Eric Schulte <eschulte@grammatech.com>
_srcname=gtirb
pkgname=gtirb-git
-pkgver=v1.1.0.r165.g8449f1d6
+pkgver=v1.4.7.r0.gb3094954
pkgrel=1
pkgdesc="GrammaTech Intermediate Representation for Binaries"
arch=('x86_64')
url="https://github.com/grammatech/gtirb"
license=('MIT')
-optdepends=('boost: build against system boost'
- # Installed protobuf package also dramatically reduces build time.
- 'protobuf: multi-language access to serialized GTIRB')
-depends=()
-makedepends=('git' 'cmake' 'python' 'doxygen' 'graphviz')
+depends=('protobuf')
+makedepends=('git' 'cmake' 'python' 'doxygen' 'graphviz' 'boost')
provides=('gtirb')
source=('git://github.com/grammatech/gtirb.git')
sha512sums=('SKIP')
@@ -24,7 +21,7 @@ pkgver() {
build() {
cd "$_srcname/"
- cmake . -Bbuild -DCMAKE_INSTALL_PREFIX=/usr -DCMAKE_CXX_COMPILER=clang++ -DGTIRB_CL_API=OFF
+ cmake . -Bbuild -DCMAKE_INSTALL_PREFIX=/usr -DGTIRB_CL_API=OFF
cmake --build build --target all doc
}