summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorEric Schulte2020-04-02 07:15:52 -0400
committerEric Schulte2020-04-02 07:15:52 -0400
commitcda0c91893c38c539fc4907af24a2322193af7b2 (patch)
treee4c3c6720a1337dda98fe97619a1af91d322d656 /PKGBUILD
parent606b22d87188b4179ef4da2ed70473c38d56e044 (diff)
downloadaur-cda0c91893c38c539fc4907af24a2322193af7b2.tar.gz
Disable non-C++ APIs, fix broken internal source
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD5
1 files changed, 2 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index b9f4bb69e010..dcf52bfe8ab3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Maintainer: Eric Schulte <eschulte@grammatech.com>
_srcname=gtirb
pkgname=gtirb-git
-pkgver=v0.2.0.r734.gf57e6cb9
+pkgver=v1.2.0.r91.g2aa2dcec
pkgrel=1
pkgdesc="GrammaTech Intermediate Representation for Binaries"
arch=('x86_64')
@@ -12,7 +12,6 @@ optdepends=('boost: build against system boost'
# Installed protobuf package also dramatically reduces build time.
'protobuf: multi-language access to serialized GTIRB')
depends=()
-# graphviz -- to build the docs
makedepends=('git' 'cmake' 'python' 'doxygen' 'graphviz')
provides=('gtirb')
source=('git://github.com/grammatech/gtirb.git')
@@ -25,7 +24,7 @@ pkgver() {
build() {
cd "$_srcname/"
- cmake . -Bbuild -DCMAKE_INSTALL_PREFIX=/usr -DCMAKE_CXX_COMPILER=clang++
+ cmake . -Bbuild -DCMAKE_INSTALL_PREFIX=/usr -DCMAKE_CXX_COMPILER=clang++ -DGTIRB_PY_API=OFF -DGTIRB_CL_API=OFF
cmake --build build --target all doc
}