summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJoaquin2018-01-07 09:37:58 -0500
committerJoaquin2018-01-07 09:37:58 -0500
commitc8498bd51bba29c10600e37df0ed5a53b3bcae98 (patch)
tree68502ab214647321d14770e26b6738b4003c862e /PKGBUILD
downloadaur-c8498bd51bba29c10600e37df0ed5a53b3bcae98.tar.gz
Updating Version & removing unnecessary dependencies
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD32
1 files changed, 32 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..efbe9fab7505
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Joaquin Garmendia <joaquingc123@gmail.com>
+# Contributor: Orestis Floros <orestisf1993@gmail.com>
+
+pkgname=gtk-arc-flatabulous-theme-git
+_pkgname=arc-flatabulous-theme
+pkgver=709.1b1b7c9
+pkgrel=1
+pkgdesc="Arc theme with Flatabulous window controls."
+arch=('any')
+url="https://github.com/andreisergiu98/${_pkgname}"
+license=('GPL3')
+makedepends=('git' 'gtk3')
+optdepends=('gtk-engine-murrine: for gtk2 themes'
+ 'gnome-themes-standard: for gtk2 themes'
+ 'arc-icon-theme: recommended icon theme')
+source=("${_pkgname}"::"git+${url}")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "${srcdir}/${_pkgname}"
+ echo "$(git rev-list --count HEAD).$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd "${srcdir}/${_pkgname}"
+ ./autogen.sh --prefix=/usr
+}
+
+package() {
+ cd "${srcdir}/${_pkgname}"
+ make DESTDIR="${pkgdir}" install
+}