summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorhmk2024-03-16 23:50:46 +0100
committerhmk2024-03-16 23:50:46 +0100
commitd220641ee20a6c5ae07ee6fe4d55b0312f21d171 (patch)
tree968f92885064f8d1c024876cb474ba0f466e08b4 /PKGBUILD
parentea4a117e9e0d037f3209542f863f4a5400f2022a (diff)
downloadaur-gtk-gnutella-git.tar.gz
PKGBUILD and repo cleanup
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD29
1 files changed, 10 insertions, 19 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 00d7da8f8da6..eb0ce9d37e9a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,42 +1,33 @@
# Maintainer: Herbert Knapp <herbert.knapp@edu.uni-graz.at>
pkgname=gtk-gnutella-git
pkgver=1.2.3.r8.g0cbba2f8b
-pkgrel=2
+pkgrel=3
pkgdesc='Efficient Gnutella 2 client (latest git version)'
arch=('i686' 'x86_64')
url='http://gtk-gnutella.sourceforge.net/'
-license=('GPL')
+license=('GPL-2.0-or-later')
depends=('gtk2' 'desktop-file-utils')
makedepends=('git')
provides=("${pkgname%-git}")
conflicts=("${pkgname%-git}")
replaces=()
backup=()
-options=('strip' '!buildflags')
+options=('!lto')
install="${pkgname}.install"
-_repo='https://github.com/gtk-gnutella/gtk-gnutella'
-_branch='devel'
-source=("${pkgname}.install" 'connections-hmk.patch' 'timeout-hmk.patch')
-md5sums=('0b6211b511da48346cecdc1d2f963c76' '126734defaa7c5b77cf0baef19c47d2c' '6f0401e9241df4f28b3fbe1bde954651')
+source=("${pkgname}.install" "${pkgname}::git+https://github.com/gtk-gnutella/gtk-gnutella.git#branch=devel")
+md5sums=('0b6211b511da48346cecdc1d2f963c76' 'SKIP')
pkgver() {
- cd ${pkgbase} && git describe --long | sed -e 's/^v\(.*\)-\([0-9]\+\)-\(g.*\)/\1.r\2.\3/'
-}
-
-prepare() {
- git clone -b ${_branch} --recursive ${_repo} ${pkgbase}
- cd ${pkgbase}
-# patch -p1 < ../connections-hmk.patch
-# patch -p1 < ../timeout-hmk.patch
+ cd ${pkgname}
+ git describe --long | sed -e 's/^v\(.*\)-\([0-9]\+\)-\(g.*\)/\1.r\2.\3/'
}
build() {
- cd ${pkgbase}
- ./build.sh --cc=gcc --prefix=/usr #--cflags="-Os" --enable-halloc
+ cd ${pkgname}
+ ./build.sh --cc=gcc --prefix=/usr
}
package() {
- cd ${pkgbase}
+ cd ${pkgname}
make install INSTALL_PREFIX="${pkgdir}/"
- strip -s ${pkgdir}/usr/bin/gtk-gnutella
}