summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorhmk2022-03-29 19:42:35 +0200
committerhmk2022-03-29 19:42:35 +0200
commit2201273454e71e1b379277e9522886fb4f7bcba0 (patch)
treeca11f80b332c947c346d059fd3318fce1fb65178 /PKGBUILD
parent3133437925a138d1dd0ca8f56111e50205a06031 (diff)
downloadaur-2201273454e71e1b379277e9522886fb4f7bcba0.tar.gz
Update PKGBUILD
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD26
1 files changed, 15 insertions, 11 deletions
diff --git a/PKGBUILD b/PKGBUILD
index b2375a1fbf91..10e3fb00efa5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,10 +1,10 @@
# Maintainer: Herbert Knapp <herbert.knapp@edu.uni-graz.at>
pkgname=gtk-gnutella-git
-pkgver=1.1.9.r23.g76f8669
+pkgver=1.2.2.r0.gadc121a3e
pkgrel=1
-pkgdesc="Efficient Gnutella 2 client (latest git version)"
+pkgdesc='Efficient Gnutella 2 client (latest git version)'
arch=('i686' 'x86_64')
-url="http://gtk-gnutella.sourceforge.net/"
+url='http://gtk-gnutella.sourceforge.net/'
license=('GPL')
depends=('gtk2' 'desktop-file-utils')
makedepends=('git')
@@ -12,27 +12,31 @@ provides=("${pkgname%-git}")
conflicts=("${pkgname%-git}")
replaces=()
backup=()
-options=()
+options=('strip')
install="${pkgname}.install"
-source=("${pkgname}::git://github.com/gtk-gnutella/gtk-gnutella.git" "${pkgname}.install")
-md5sums=('SKIP' '0b6211b511da48346cecdc1d2f963c76')
+_repo='https://github.com/gtk-gnutella/gtk-gnutella'
+_branch='devel'
+source=("${pkgname}.install" 'connections-hmk.patch' 'timeout-hmk.patch')
+md5sums=('0b6211b511da48346cecdc1d2f963c76' '126734defaa7c5b77cf0baef19c47d2c' '6f0401e9241df4f28b3fbe1bde954651')
-pkgver() {
- cd ${pkgbase} && git describe --tags | sed -e 's/^v\(.*\)-\([0-9]\+\)-\(g.*\)/\1.r\2.\3/'
+pkgver() {
+ cd ${pkgbase} && git describe --long | sed -e 's/^v\(.*\)-\([0-9]\+\)-\(g.*\)/\1.r\2.\3/'
}
prepare() {
+ git clone -b ${_branch} --recursive ${_repo} ${pkgbase}
cd ${pkgbase}
- git submodule update --init
+# patch -p1 < ../connections-hmk.patch
+# patch -p1 < ../timeout-hmk.patch
}
build() {
cd ${pkgbase}
- ./build.sh --cc=gcc --prefix=/usr --cflags="-Os" --enable-halloc
+ ./build.sh --cc=gcc --prefix=/usr #--cflags="-Os" --enable-halloc
}
package() {
cd ${pkgbase}
make install INSTALL_PREFIX="${pkgdir}/"
strip -s ${pkgdir}/usr/bin/gtk-gnutella
-} \ No newline at end of file
+}