summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorNarrat2015-07-25 16:12:23 +0200
committerNarrat2015-07-25 16:12:23 +0200
commita03b1a05ec66adda3c31519c225013b66e67946b (patch)
treef9ee1e1bf55f69f4ade8c081aa96085705401efb /PKGBUILD
parent266786509d22aa3be9a17fd357f5ceb14754455f (diff)
downloadaur-gtk-sharp-git.tar.gz
gtk-sharp-git: Add conflicts/provides
As this package conflicts the repo gtk-sharp-3 package, since it got added there. Added --tags to pkgver() so the correct version is displayed
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD6
1 files changed, 4 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 3e45ff0d0383..6b15038115e4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
_pkgname=gtk-sharp
pkgname=$_pkgname-git
-pkgver=2.99.2.r72.g08f4ae2
+pkgver=2.99.3.r39.g89b2dae
pkgrel=1
pkgdesc="C# bindings to the cross platform Gtk+ GUI toolkit (git-master)"
arch=('i686' 'x86_64')
@@ -11,13 +11,15 @@ url="http://www.mono-project.com/docs/gui/gtksharp/"
license=('LGPL')
depends=('mono' 'gtk3')
makedepends=('git')
+conflicts=('gtk-sharp-3')
+provides=('gtk-sharp-3=2.99.3')
source=('git://github.com/mono/gtk-sharp.git#branch=master')
md5sums=('SKIP')
pkgver() {
cd $_pkgname
- git describe --long | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
}
build() {