summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorpzl2015-08-08 11:47:33 -0400
committerpzl2015-08-08 11:47:33 -0400
commit530844587475c192bc4b3b7c8126bb1753b4ebe1 (patch)
tree251beb53e0f749fba0a9254c3638509d14187e71 /PKGBUILD
downloadaur-530844587475c192bc4b3b7c8126bb1753b4ebe1.tar.gz
add this package to aur4/git
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD33
1 files changed, 33 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0ca4218c5804
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: pzl <alsoelp@gmail.com>
+# Contributor: Ner0
+# Contributor: Sauyon Lee <sauyonl@sauyon.com>
+
+pkgname=gtk-theme-flatstudio
+pkgver=1.03
+pkgrel=2
+pkgdesc="Flat, simple and clean GTK3 theme"
+arch=('any')
+url="http://gnome-look.org/content/show.php?content=154296"
+license=('GPL3')
+depends=('gtk-engine-unico' 'gtk-engine-murrine')
+options=('!strip')
+source=("http://gnome-look.org/CONTENT/content-files/154296-FlatStudio-1.03.tar.gz")
+md5sums=('4a22cba22de2086b108bf8119473453f')
+
+prepare() {
+ # fix for gtk 3.11.2+
+ echo -e '\nGtkBox { background-color: transparent; }' | \
+ tee -a FlatStudio{,Dark,Gray,Light}/gtk-3.0/gtk.css > /dev/null
+}
+
+package() {
+ install -dm755 "$pkgdir/usr/share/themes/"
+ install -Dm644 FlatStudio/LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+
+ rm -rf FlatStudio/{LICENSE,*.txt,*.tar.gz}
+
+ cp -rf FlatStudio{,Dark,Gray,Light} "$pkgdir/usr/share/themes/"
+
+ find "$pkgdir/" -type d -exec chmod 755 "{}" \;
+ find "$pkgdir/" -type f -exec chmod 644 "{}" \;
+}