summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorGordian Edenhofer2015-05-23 14:10:08 +0200
committerGordian Edenhofer2015-05-23 14:10:08 +0200
commit29c307f267cd5449c0549f28b7d16a4ea3b6aeb1 (patch)
treec3dfb68ee8afdb89a1bcfbb4a185773619b33b83 /PKGBUILD
downloadaur-29c307f267cd5449c0549f28b7d16a4ea3b6aeb1.tar.gz
initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD30
1 files changed, 30 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7105f3aa6e35
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Gordian Edenhofer <gordian.edenhofer[at]yahoo[dot]de>
+# Contributor: Gustavo Castro <gustawho[at]gmail[dot]com>
+# Submitter: acrox999 <acrox999[at]gmail[dot]com>
+
+pkgname=gtk-theme-iris-light-git
+_pkgname=iris-light
+pkgver=103.a416581
+pkgrel=1
+pkgdesc="A flat theme that uses varying shades and tones to create distinction and a modern experience. It supports Gtk 3.10, Gtk 3.12 and Gtk 2 (using the Murrine engine)."
+arch=('any')
+url="http://thevirtualdragon.deviantart.com/art/Iris-Light-Beta-428948909"
+license=('GPL3')
+depends=('gtk3' 'gtk-engine-murrine')
+makedepends=('git')
+provides=('gtk-theme-iris-light')
+changelog=('CHANGELOG')
+source=(${_pkgname}::'git+https://github.com/xyl0n/iris-light.git')
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "${srcdir}/${_pkgname}"
+ echo $(git rev-list --count HEAD).$(git rev-parse --short HEAD)
+}
+
+package() {
+ cd "${srcdir}/${_pkgname}"
+ install -dm755 "${pkgdir}/usr/share/themes/${_pkgname}"
+ rm -rf {.git,CREDITS,LICENSE,README,README.md}
+ cp -dpr --no-preserve=ownership . "${pkgdir}/usr/share/themes/${_pkgname}/"
+}