summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJeija2018-03-27 08:03:37 +0200
committerJeija2018-03-27 08:03:37 +0200
commite1b83faa74a8ac305c00f84f0467ce3df6dc8b90 (patch)
tree1df923998ed3408a56ad32cae9891d0687f0a85c /PKGBUILD
parentae0fdb8fb346b37279b658abc131194e5065b9cc (diff)
downloadaur-e1b83faa74a8ac305c00f84f0467ce3df6dc8b90.tar.gz
Update to GTK+ 3.22.29
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD20
1 files changed, 8 insertions, 12 deletions
diff --git a/PKGBUILD b/PKGBUILD
index f6727ee7160e..e464d857ef57 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: twilinx <twilinx@mesecons.net>
pkgname=gtk3-typeahead
-pkgver=3.22.26+47+g3a1a7135a2
+pkgver=3.22.29+4+gb485cf91b5
pkgrel=1
conflicts=(gtk3)
provides=("gtk3=$pkgver" gtk3-print-backends)
@@ -13,40 +13,36 @@ install=gtk3.install
depends=(atk cairo libxcursor libxinerama libxrandr libxi libepoxy gdk-pixbuf2 dconf
libxcomposite libxdamage pango shared-mime-info at-spi2-atk wayland libxkbcommon
adwaita-icon-theme json-glib librsvg wayland-protocols desktop-file-utils mesa
- cantarell-fonts colord rest libcups libcanberra)
+ cantarell-fonts colord rest libcups libcanberra libcloudproviders)
makedepends=(gobject-introspection gtk-doc git glib2-docs sassc)
license=(LGPL)
-_commit=3a1a7135a276f2b6336c7566f6342da739a41d39 # gtk-3-22
-source=("git://git.gnome.org/gtk+#commit=$_commit"
- 0001-entry-Undo-ABI-breakage-from-addition-of-insert_emoj.patch
+_commit=b485cf91b53cd21fad8b4ff35fef53e4d1a9f009 # gtk-3-22
+source=("git+https://gitlab.gnome.org/GNOME/gtk.git#commit=$_commit"
settings.ini
gtk-query-immodules-3.0.hook
typeahead.patch)
sha256sums=('SKIP'
- '3a52d723db863564bea9245d5f65b1dc5c3ca20ee190fca249eb8bd8fdbc5c0b'
'01fc1d81dc82c4a052ac6e25bf9a04e7647267cc3017bc91f9ce3e63e5eb9202'
'de46e5514ff39a7a65e01e485e874775ab1c0ad20b8e94ada43f4a6af1370845'
'5006fa1dcea9aa74766196ec5c18e5172d7287195c2a49ffcd0adc13bc6e62c1')
prepare() {
- cd gtk+
+ cd gtk
# Typeahead-specific changes
patch gtk/gtkfilechooserwidget.c -i $srcdir/typeahead.patch
- # https://bugs.archlinux.org/task/56474
- patch -Np1 -i ../0001-entry-Undo-ABI-breakage-from-addition-of-insert_emoj.patch
-
NOCONFIGURE=1 ./autogen.sh
}
build() {
- cd gtk+
+ cd gtk
CXX=/bin/false ./configure --prefix=/usr \
--sysconfdir=/etc \
--localstatedir=/var \
--disable-schemas-compile \
+ --enable-cloudproviders \
--enable-x11-backend \
--enable-broadway-backend \
--enable-wayland-backend \
@@ -61,7 +57,7 @@ build() {
package() {
install=gtk3.install
- cd gtk+
+ cd gtk
make DESTDIR="$pkgdir" install
install -Dm644 ../settings.ini "$pkgdir/usr/share/gtk-3.0/settings.ini"
install -Dm644 ../gtk-query-immodules-3.0.hook "$pkgdir/usr/share/libalpm/hooks/gtk-query-immodules-3.0.hook"