summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorShengyu Zhang2018-06-28 14:33:25 +0800
committerShengyu Zhang2018-06-28 14:34:01 +0800
commit6f8459a9f35a68100f7c9da4c0637194cd4a0c37 (patch)
tree9f6382a1e51f5c6f1da13eb73f50a8cc2cb86b7e /PKGBUILD
parentb00c415566c0895a7a718b8f5d017ca1155464c2 (diff)
downloadaur-6f8459a9f35a68100f7c9da4c0637194cd4a0c37.tar.gz
upgpkg: gtk4 3.94.0
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD32
1 files changed, 15 insertions, 17 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 04687788ec32..c1617ad5b127 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,9 +3,9 @@
# Based on gtk4-git
pkgname=gtk4
-pkgver=3.93.0
-_tag_commit_id=3f012f6d018708f895663468e2c788b448cddc3d
-pkgrel=3
+pkgver=3.94.0
+_tag_commit_id=faba0f0145b1281facba20fb90699e3db594fbb0
+pkgrel=1
pkgdesc="GObject-based multi-platform GUI toolkit"
arch=('i686' 'x86_64')
url="https://www.gtk.org/"
@@ -17,7 +17,7 @@ depends=('hicolor-icon-theme'
'at-spi2-atk'
'atk>=2.15.1'
'dconf'
- 'glib2>=2.53.7'
+ 'glib2>=2.55.0'
'libepoxy>=1.4'
'libxcomposite'
'libxcursor'
@@ -26,15 +26,16 @@ depends=('hicolor-icon-theme'
'libxrandr'
'mesa'
'pango'
- 'wayland>=1.9.91'
- 'wayland-protocols>=1.9'
+ 'wayland>=1.14.91'
+ 'wayland-protocols>=1.12'
'graphene>=1.5.1'
'json-glib'
'colord'
'libcups'
'rest'
'vulkan-icd-loader'
- 'gdk-pixbuf2')
+ 'gdk-pixbuf2'
+ 'gst-plugins-bad')
makedepends=('gobject-introspection'
'gtk-doc'
'meson'
@@ -43,29 +44,27 @@ makedepends=('gobject-introspection'
optdepends=('gnome-icon-theme: Default icon theme'
'gnome-themes-standard: Default widget theme'
'gdk-pixbuf2: An image loading library')
-source=("https://gitlab.gnome.org/GNOME/gtk/repository/${pkgver}/archive.tar.gz"
+source=("https://gitlab.gnome.org/GNOME/gtk/-/archive/${pkgver}/gtk-${pkgver}.tar.gz"
'gtk4.install'
- 'gtk4-query-immodules.hook'
'gtk4-update-icon-cache.hook'
'gtk4-update-icon-cache.script'
'settings.ini')
-sha512sums=('b3c2c8937da4063e2602a568d05e772147d6f5504a31fc9104ba76579903a0cc562d3bf0e1b3521eade864ee981caa4bc08032a3152c3a08b5057bceec137126'
+sha512sums=('84027918ae582be8982ecde859c1e9321f97283a84e45abb87356c1c0214c3f5462a74470ee9f2511a4b7981eb53bd9c4c3c2416039c21d5afe73ddbfd1ae7ed'
'5dcb698a15e7d5f4611c9357782d475052944cc71e73351238ffb5dfbe18d1bd1b62289da7f8066cde256c4339de5efa982088f47781876f5d8317f92b87f79f'
- '1dbcce0a3e17ee05b579613adba25feff692f6626155e91fa6859e5f176753201b5ceffa8c9c7c897cf945aeeb32fbd28affa24050dfc0d65237733964bf28de'
'9d3bb80afb3a00dc50402d32476719daaeab017e1a066425bb602316b534d0a9899d48734a84f70af1066ed104df0491264383a34969dfad2ea9828fb41b9b6b'
'805cf12606c738d0442d8af415223d3faada93c933b563b7c4c1d5e0c16d2d21435406add1fcc69300fb2fe534f2d0ddbf50b2c0463fc7462109d0f7802ccef1'
'1642d77622d61234e316e8fcbc803a6a5556c606e37e56aa5981ef2f2df85bfa959c31b5d1bff248b340760e1178281cb0d7abdf540c5f7d4b62cb383a67c685')
-install="gtk4.install"
+install=gtk4.install
build() {
- cd gtk-${pkgver}-${_tag_commit_id}
+ cd gtk-${pkgver}
meson --prefix=/usr \
--sysconfdir=/etc \
--localstatedir=/var \
--libdir=/usr/lib \
- -Denable-broadway-backend=true \
- -Denable-vulkan=yes \
+ -Dbroadway-backend=true \
+ -Dvulkan=yes \
_build .
cd _build
@@ -74,12 +73,11 @@ build() {
}
package() {
- cd gtk-${pkgver}-${_tag_commit_id}/_build
+ cd gtk-${pkgver}/_build
DESTDIR="$pkgdir" ninja install
install -Dm 644 "../../settings.ini" "$pkgdir"/usr/share/gtk-4.0/settings.ini
- install -Dm 644 "../../gtk4-query-immodules.hook" "$pkgdir"/usr/share/libalpm/hooks/gtk4-query-immodules.hook
install -D "gtk/gtk4-update-icon-cache" "$pkgdir"/usr/bin/gtk4-update-icon-cache
install -Dm 644 "../../gtk4-update-icon-cache.hook" "$pkgdir"/usr/share/libalpm/hooks/gtk4-update-icon-cache.hook
install -Dm 755 "../../gtk4-update-icon-cache.script" "$pkgdir"/usr/share/libalpm/scripts/gtk4-update-icon-cache