summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorRod Kay2021-06-22 12:47:49 +1000
committerRod Kay2021-06-22 12:47:49 +1000
commitb5a6f1b206e7472033e34a0f61c015ceb409a8e8 (patch)
treeac0b20ecfe2663c65858f746046e6262bfaf3f44 /PKGBUILD
parent807a5276526e477cfe69bb4282d614f07e984285 (diff)
downloadaur-b5a6f1b206e7472033e34a0f61c015ceb409a8e8.tar.gz
Install the licenses.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD14
1 files changed, 12 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 9c2da8d89d21..823ecdd4c194 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,12 +4,12 @@
pkgname=gtkada
epoch=1
pkgver=21.0.0
-pkgrel=2
+pkgrel=3
pkgdesc='Ada bindings for the Gtk+ library.'
url='https://github.com/AdaCore/gtkada'
arch=('i686' 'x86_64')
-license=('GPL')
+license=('GPL3' 'custom')
depends=('gcc-ada' 'gtk3')
makedepends=('gprbuild')
@@ -39,4 +39,14 @@ package()
cd "$srcdir/$pkgname-$pkgver"
make -j1 PROCESSORS=1 DESTDIR="$pkgdir" install
+
+ # Install the license.
+ install -D -m644 \
+ "COPYING3" \
+ "$pkgdir/usr/share/licenses/$pkgname/COPYING3"
+
+ # Install the custom license.
+ install -D -m644 \
+ "COPYING.RUNTIME" \
+ "$pkgdir/usr/share/licenses/$pkgname/COPYING.RUNTIME"
}