summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorCarsten Teibes2013-12-05 03:16:56 +0100
committerCarsten Teibes2013-12-05 03:16:56 +0100
commit43f3bfc8974fcfdcf8c222ac363bab5f9da413f1 (patch)
tree86acffa3d5f0740b7e7116ef0d25444cda3cf6e6 /PKGBUILD
parent7ecb6600b99d6e81dae41a652e80f658839fab25 (diff)
downloadaur-43f3bfc8974fcfdcf8c222ac363bab5f9da413f1.tar.gz
[fix] Enable plugins
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD46
1 files changed, 41 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 2266bea7aa6a..5ae432c053f0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,18 +1,24 @@
# Maintainer: carstene1ns <arch carsten-teibes de>
# Contributor: Jan Böhringer <janboe@gmail.com>
# Contributor: Frédérik Paradis <fredy_14@live.fr>
+# Contributor: GI_Jack <GI_Jack@hushmail.com>
-# You can also build this package with gtk3, just change lines 15+26.
+##### OPTIONS #####
+_gtk_version=2
+_nemo_plugin=y
+_nautilus_plugin=n
+_thunar_plugin=n
+###################
pkgname=gtkhash
pkgver=0.7.0
-pkgrel=1
+pkgrel=2
pkgdesc="A GTK+ utility for computing message digests or checksums."
arch=('i686' 'x86_64' 'mips64el')
url="http://gtkhash.sourceforge.net/"
license=('GPL')
makedepends=('intltool')
-depends=('gtk2' 'dconf')
+depends=('dconf')
install=$pkgname.install
source=(http://downloads.sourceforge.net/$pkgname/$pkgname-$pkgver.tar.xz
gtkhash.desktop)
@@ -21,11 +27,41 @@ md5sums=('f80567fdd8c4435e03b837d54f38f1bb'
sha256sums=('161d4f27f2d412c8cb3f566ca3aa8144942bbf836c18bcb1e5f79451e6f5dfdd'
'SKIP')
+# gtk version
+if [ "$_gtk_version" = "3" ]; then
+ _pkgoptions="$_pkgoptions --with-gtk=3.0"
+ depends=("${depends[@]}" "gtk3")
+else
+ _pkgoptions="$_pkgoptions --with-gtk=2.0"
+ depends=("${depends[@]}" "gtk2")
+fi
+
+# nemo plugin
+if [ "$_nemo_plugin" = "y" ]; then
+ _pkgoptions="$_pkgoptions --enable-nemo"
+ makedepends=("${makedepends[@]}" "nemo")
+ optdepends=("${optdepends[@]}" "nemo: filemanager plugin")
+fi
+
+# nautilus plugin
+if [ "$_nautilus_plugin" = "y" ]; then
+ _pkgoptions="$_pkgoptions --enable-nautilus"
+ makedepends=("${makedepends[@]}" "libnautilus-extension")
+ optdepends=("${optdepends[@]}" "nautilus: filemanager plugin")
+fi
+
+# thunar plugin
+if [ "$_thunar_plugin" = "y" ]; then
+ _pkgoptions="$_pkgoptions --enable-thunar"
+ makedepends=("${makedepends[@]}" "thunar")
+ optdepends=("${optdepends[@]}" "thunar: filemanager plugin")
+fi
+
build() {
cd $pkgname-$pkgver
- ./configure --prefix=/usr --disable-schemas-compile \
- --enable-linux-crypto --enable-nettle --with-gtk=2.0
+ ./configure --prefix=/usr --disable-schemas-compile --enable-gtkhash \
+ --enable-linux-crypto --enable-nettle $_pkgoptions
make
}