summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorSam Burgos2021-12-29 16:24:25 -0600
committerSam Burgos2021-12-29 16:24:25 -0600
commitccdc314230c0882c108d77559cdfb62597228404 (patch)
tree1df7a1201f21796b0be50de4af6d1dba4853cc1d /PKGBUILD
downloadaur-ccdc314230c0882c108d77559cdfb62597228404.tar.gz
added new gtkhash-nautilus package to separate from standalone application and other filemanager plugins
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD59
1 files changed, 59 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1068486ef7a2
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,59 @@
+# Maintainer: Sam Burgos < santiago dot burgos1089 at gmail dot com >
+# Contributor: carstene1ns <arch carsten-teibes de> - http://git.io/ctPKG
+# Contributor: Jan Böhringer <janboe@gmail.com>
+# Contributor: Frédérik Paradis <fredy_14@live.fr>
+# Contributor: GI_Jack <GI_Jack@hushmail.com>
+
+pkgname=gtkhash-nautilus
+pkgver=1.4
+pkgrel=4
+pkgdesc="A GTK+ utility for computing message digests or checksums (Gtkhash with Nautilus filemanager plugin)"
+arch=('x86_64')
+url="https://github.com/tristanheaven/gtkhash"
+license=('GPL')
+depends=(
+ 'dconf'
+ 'gtk3'
+ 'libb2'
+ 'libnautilus-extension'
+ 'nettle'
+)
+
+makedepends=(
+ 'dconf'
+ 'gtk3'
+ 'intltool'
+ 'libnautilus-extension'
+ 'librsvg'
+ 'nettle'
+ 'xdg-utils'
+)
+provides=(${pkgname})
+conflicts=(
+ gtkhash
+ gtkhash-caja
+ gtkhash-nemo
+ gtkhash-thunar
+)
+source=("${url}/releases/download/v$pkgver/gtkhash-$pkgver.tar.xz")
+sha256sums=('20b57dbb8f6c6d7323f573c111a11640603a422c5f9da7b302a4981e4adc37c4')
+
+build() {
+ cd gtkhash-$pkgver
+
+ ./configure --prefix=/usr \
+ --disable-schemas-compile \
+ --enable-gtkhash \
+ --enable-linux-crypto \
+ --enable-nettle \
+ --disable-blake2 \
+ --with-gtk=3.0 \
+ --enable-nautilus
+
+ make
+}
+
+package() {
+
+ make -C gtkhash-$pkgver/src/nautilus DESTDIR="$pkgdir/" install
+}