summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorSteven Allen2016-06-11 15:46:33 -0700
committerSteven Allen2016-06-11 15:46:33 -0700
commitb061a581818f782c6f2d6a49f51657b003babdb2 (patch)
tree2ad7ebcb9f5ed189ae57c6b7cb57309963ccaa39 /PKGBUILD
parentdb4e8ebc7333f199987ac8ef866fd230322b7e47 (diff)
downloadaur-b061a581818f782c6f2d6a49f51657b003babdb2.tar.gz
Fix PKGBUILD
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD21
1 files changed, 8 insertions, 13 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 48cc389fc271..88f684f39764 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,5 +1,4 @@
-# $Id: PKGBUILD,v 1.12 2003/11/06 08:26:13 dorphell Exp $
-# Maintainer: Tobias Mueller <gtklp@sirtobi.com>
+# Maintainer: Steven Allen <steven@stebalien.com>
# Contributor: Tobias Mueller <gtklp@sirtobi.com>
pkgname=gtklp
pkgver=1.3.1
@@ -8,23 +7,19 @@ pkgdesc="a graphical frontend for cups, the linux printing system"
arch=(i686 x86_64)
url="http://gtklp.sirtobi.com/"
license=('GPL')
-groups=
-provides=
depends=('cups' 'gtk2')
-makedepends=
-conflicts=
-replaces=
-backup=
-install=
-source=(https://sourceforge.net/projects/gtklp/files/gtklp/$pkgver/gtklp-$pkgver.src.tar.gz/download)
-md5sums=('4b77d070aafeab45d134a4f9a12883bb')
+source=(gtklp-$pkgver.src.tar.gz::https://sourceforge.net/projects/gtklp/files/gtklp/$pkgver/gtklp-$pkgver.src.tar.gz/download)
+sha256sums=('734f9b0edb4f01ffce1288553150966231253a5bf4bd76db739ee180a1f39fdb')
build() {
cd $srcdir/$pkgname-$pkgver
- aclocal -I m4
+
+ # The configure script is really out of date...
+ aclocal -I m4
autoheader --force
- autoconf --force
+ autoconf --force
automake --add-missing --copy --include-deps --foreign --force-missing
+
./configure --prefix=/usr
make
}