summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorsurefire2019-08-19 23:00:55 +0300
committersurefire2019-08-19 23:00:55 +0300
commit4dc3fde5a8310844b6b837572d1b5a6cc1d11b67 (patch)
treec6265dbf99f40f853d9cf2f6fb3936596425b399 /PKGBUILD
parentaeb2b6f3952ec5059a57b9f8dc1ebf90fa3141e6 (diff)
downloadaur-4dc3fde5a8310844b6b837572d1b5a6cc1d11b67.tar.gz
qt 5.13
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD16
1 files changed, 6 insertions, 10 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 1e3276aabac7..ff4e0ff1647b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,5 +1,5 @@
pkgname=gtkplatform
-pkgver=0.2.4+4+ga9b8447
+pkgver=0.2.4+5+gda0e695
pkgrel=1
pkgdesc="Run Qt applications using gtk+ as a windowing system"
arch=('x86_64')
@@ -8,21 +8,18 @@ license=('LGPL3' 'GPL2')
conflicts=('qt-gtk-platform-plugin')
depends=('gtk3' 'libnotify' 'qt5-base')
makedepends=('git')
-_commit=a9b84470ceefa481beef598c45bd7cae3042a61c
+_commit=da0e6959ae4dcc4db1bf44058883bea2207bf73b
source=(
"git+$url.git#commit=$_commit"
- '50-gtkplatform.conf'
)
-md5sums=('SKIP'
- 'feb8d574489bed9bd91dae7c3b5b54a1')
-sha512sums=('SKIP'
- 'd96788c66228b336c1932531221cc92902d40986d378bfcea15e3b53b0ba2a1a39568c9592e1745145c60b569e8909af095292e95faee6ef284e7fcb263b907f')
+md5sums=('SKIP')
+sha512sums=('SKIP')
prepare() {
cd $pkgname
- # Fix build under GCC 8.2.1 https://github.com/CrimsonAS/gtkplatform/pull/46
- git merge --squash d1ac6cbb011a3f72a5767bf00c47b9fcbcf9d935
+ #Fix build on Qt 5.13 https://github.com/CrimsonAS/gtkplatform/pull/48
+ git merge --squash 9434258d4fda66729eaab25105583ebe5aca8134
}
pkgver() {
@@ -42,5 +39,4 @@ package() {
cd $pkgname
make INSTALL_ROOT="$pkgdir" install
- install -Dt "$pkgdir/usr/lib/environment.d" -m0644 ../50-gtkplatform.conf
}