summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorxduugu2017-10-08 23:10:43 +0200
committerxduugu2017-10-08 23:10:43 +0200
commitb23605cf97a7b54e4d53e0e3e0b0cabf144f228a (patch)
tree23d191fa39b49097f9fe087a7d6e29d66c8cfa43 /PKGBUILD
downloadaur-b23605cf97a7b54e4d53e0e3e0b0cabf144f228a.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD22
1 files changed, 22 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2c66d0a3117e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+pkgname=gtkplatform
+pkgver=0.1.0
+pkgrel=1
+pkgdesc="Run Qt applications using gtk+ as a windowing system"
+arch=('i686' 'x86_64')
+url="https://github.com/CrimsonAS/gtkplatform"
+license=('LGPL3' 'GPL2')
+depends=('gtk3' 'libnotify' 'qt5-base')
+source=("$pkgname-$pkgver.tar.gz::https://github.com/CrimsonAS/gtkplatform/archive/$pkgver.tar.gz")
+md5sums=('c3fc599753d4b93b7bfb5d4446f073dc')
+sha512sums=('0100127e3546df3caf7698414051003ddc4e61d5b32a7ea0b129489237f9f74dfc0b5fd0148e66a89dfd372c6002554d5568f547054be42b557060e9114328e6')
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+ qmake
+ make
+}
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+ make INSTALL_ROOT="$pkgdir/" install
+}