summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorArtem Vorotnikov2015-11-11 23:14:18 +0300
committerArtem Vorotnikov2015-11-11 23:14:18 +0300
commit1f27b936e1298bf042827a7929b39b8881b9dde2 (patch)
treec1a5d8f9060815689d28aee7ee7241494e471620 /PKGBUILD
downloadaur-gtksourceview-highlight-haml.tar.gz
Initial import
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD25
1 files changed, 25 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c5f3487e9f74
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+_orgname=mkllnk
+_reponame=gedit-rails-extensions
+pkgbase=gtksourceview-highlight-haml
+pkgname=('gtksourceview2-highlight-haml' 'gtksourceview3-highlight-haml')
+pkgver=LATEST
+pkgrel=1
+pkgdesc='HAML syntax highlighting for gtksourceview'
+arch=('any')
+license=('GPL')
+url="https://github.com/$_orgname/$_reponame"
+source="git+https://github.com/$_orgname/$_reponame.git"
+sha512sums=SKIP
+
+package_gtksourceview2-highlight-haml() {
+ depends=('gtksourceview2' 'mime-haml')
+
+ install -m644 -D "$srcdir/$_reponame/language-specs/haml.lang" "$pkgdir/usr/share/gtksourceview-2.0/language-specs/haml.lang"
+}
+
+package_gtksourceview3-highlight-haml() {
+ depends=('gtksourceview3' 'mime-haml')
+
+ install -m644 -D "$srcdir/$_reponame/language-specs/haml.lang" "$pkgdir/usr/share/gtksourceview-3.0/language-specs/haml.lang"
+}
+