summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorArtem Vorotnikov2015-09-08 05:01:06 +0300
committerArtem Vorotnikov2015-09-08 05:01:06 +0300
commitc26ec1a0c4a8d78f467b2e939a1b253e32dada13 (patch)
tree18c5d3f86d6c37266b64fe6c0062432ceb7076b0 /PKGBUILD
downloadaur-c26ec1a0c4a8d78f467b2e939a1b253e32dada13.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD30
1 files changed, 30 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..28d48d3d292f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+_reponame='toml.lang'
+pkgbase=gtksourceview-highlight-toml
+pkgname=('gtksourceview2-highlight-toml' 'gtksourceview3-highlight-toml')
+pkgver=r8.8f3dd72
+pkgrel=1
+pkgdesc='TOML syntax highlighting for gtksourceview'
+arch=('any')
+url=('https://github.com/liv-dumea/toml.lang')
+license=('GPL')
+source=('git+https://github.com/liv-dumea/toml.lang.git')
+sha512sums=('SKIP')
+
+
+pkgver() {
+ cd "$_reponame"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package_gtksourceview2-highlight-toml() {
+ depends=('gtksourceview2')
+
+ install -Dm644 $srcdir/$_reponame/toml.lang "$pkgdir/usr/share/gtksourceview-2.0/language-specs/toml.lang"
+}
+
+package_gtksourceview3-highlight-toml() {
+ depends=('gtksourceview3')
+
+ install -Dm644 $srcdir/$_reponame/toml.lang "$pkgdir/usr/share/gtksourceview-3.0/language-specs/toml.lang"
+}
+