summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorLucki2019-11-20 16:13:25 +0100
committerLucki2019-11-20 16:13:25 +0100
commit1cbb3c47bad3e49d3efd323506dabe937f9258a2 (patch)
tree67b570f9b083f5b81ab433563d90a440b5c641c3 /PKGBUILD
parent1232e0514a202ff1569be5f04af0788c4f262372 (diff)
downloadaur-gtksourceview-lolcode.tar.gz
rename sources to something unique for shared $srcdir
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD17
1 files changed, 9 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 8a88f9aa4a5a..db7c382e74d4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,16 +9,17 @@ url="https://lolcode.org/"
license=('MIT')
makedepends=('git')
optdepends=( 'lci-git: lolcode commandline interpreter')
-source=("$pkgbase::git+https://github.com/Lucki/gtksourceview3-lolcode.git#commit=f80e35e")
-sha512sums=('SKIP')
+_commit=f80e35eaa011ea5c3643fa88992e78b6fde08fbf
+source=("$pkgbase-$pkgver-$pkgrel.src.tar.gz::https://github.com/Lucki/$pkgbase/archive/$_commit.tar.gz")
+sha512sums=('ffe712fadb0e45709b827795e9fd3b5ac89e28454982cbc0fe629cbdad8f148ba0ce3d180b89ae8769cf190707f28e8d89f4e8bcb8632feea4d10f54a3876c1e')
package_gtksourceview2-lolcode()
{
pkgdesc="lolcode syntax highlight support in gtksourceview2"
depends=('gtksourceview2')
- install -Dm644 "$pkgbase/lolcode.lang" "$pkgdir/usr/share/gtksourceview-2.0/language-specs/lolcode.lang"
- install -Dm644 "$pkgbase/LICENSE" "$pkgdir/usr/share/licenses/${pkgname[0]}/LICENSE"
+ install -Dm644 "$pkgbase-$_commit/lolcode.lang" "$pkgdir/usr/share/gtksourceview-2.0/language-specs/lolcode.lang"
+ install -Dm644 "$pkgbase-$_commit/LICENSE" "$pkgdir/usr/share/licenses/${pkgname[0]}/LICENSE"
}
package_gtksourceview3-lolcode()
@@ -26,8 +27,8 @@ package_gtksourceview3-lolcode()
pkgdesc="lolcode syntax highlight support in gtksourceview3"
depends=('gtksourceview3')
- install -Dm644 "$pkgbase/lolcode.lang" "$pkgdir/usr/share/gtksourceview-3.0/language-specs/lolcode.lang"
- install -Dm644 "$pkgbase/LICENSE" "$pkgdir/usr/share/licenses/${pkgname[1]}/LICENSE"
+ install -Dm644 "$pkgbase-$_commit/lolcode.lang" "$pkgdir/usr/share/gtksourceview-3.0/language-specs/lolcode.lang"
+ install -Dm644 "$pkgbase-$_commit/LICENSE" "$pkgdir/usr/share/licenses/${pkgname[1]}/LICENSE"
}
package_gtksourceview4-lolcode()
@@ -35,6 +36,6 @@ package_gtksourceview4-lolcode()
pkgdesc="lolcode syntax highlight support in gtksourceview4"
depends=('gtksourceview4')
- install -Dm644 "$pkgbase/lolcode.lang" "$pkgdir/usr/share/gtksourceview-4/language-specs/lolcode.lang"
- install -Dm644 "$pkgbase/LICENSE" "$pkgdir/usr/share/licenses/${pkgname[2]}/LICENSE"
+ install -Dm644 "$pkgbase-$_commit/lolcode.lang" "$pkgdir/usr/share/gtksourceview-4/language-specs/lolcode.lang"
+ install -Dm644 "$pkgbase-$_commit/LICENSE" "$pkgdir/usr/share/licenses/${pkgname[2]}/LICENSE"
}