summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorLucki2018-09-20 13:54:44 +0200
committerLucki2018-09-20 13:54:44 +0200
commit24cb3851fb611506a97dbc2b997139e7cc6df2b7 (patch)
tree38941350c93b177da65ef519775f555eab79ac01 /PKGBUILD
downloadaur-24cb3851fb611506a97dbc2b997139e7cc6df2b7.tar.gz
New pkgbase in better
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD40
1 files changed, 40 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..763d02ef6e60
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,40 @@
+# Maintainer: Lucki <https://aur.archlinux.org/account/Lucki>
+
+pkgbase=gtksourceview-lolcode
+pkgname=('gtksourceview2-lolcode' 'gtksourceview3-lolcode' 'gtksourceview4-lolcode')
+pkgver=0.1
+pkgrel=2
+arch=('any')
+url="https://lolcode.org/"
+license=('MIT')
+makedepends=('git')
+optdepends=( 'lci: lolcode commandline interpreter')
+source=("${pkgbase}::git+https://github.com/Lucki/gtksourceview3-lolcode.git#commit=f80e35e")
+sha512sums=('SKIP')
+
+package_gtksourceview2-lolcode()
+{
+ pkgdesc="lolcode syntax highlight support in gtksourceview2"
+ depends=('gtksourceview2')
+
+ install -Dm644 "${srcdir}/${pkgbase}/lolcode.lang" "${pkgdir}/usr/share/gtksourceview-2.0/language-specs/lolcode.lang"
+ install -Dm644 "${srcdir}/${pkgbase}/LICENSE" "${pkgdir}/usr/share/licenses/${pkgname[0]}/LICENSE"
+}
+
+package_gtksourceview3-lolcode()
+{
+ pkgdesc="lolcode syntax highlight support in gtksourceview3"
+ depends=('gtksourceview3')
+
+ install -Dm644 "${srcdir}/${pkgbase}/lolcode.lang" "${pkgdir}/usr/share/gtksourceview-3.0/language-specs/lolcode.lang"
+ install -Dm644 "${srcdir}/${pkgbase}/LICENSE" "${pkgdir}/usr/share/licenses/${pkgname[1]}/LICENSE"
+}
+
+package_gtksourceview4-lolcode()
+{
+ pkgdesc="lolcode syntax highlight support in gtksourceview4"
+ depends=('gtksourceview4')
+
+ install -Dm644 "${srcdir}/${pkgbase}/lolcode.lang" "${pkgdir}/usr/share/gtksourceview-4/language-specs/lolcode.lang"
+ install -Dm644 "${srcdir}/${pkgbase}/LICENSE" "${pkgdir}/usr/share/licenses/${pkgname[2]}/LICENSE"
+}