summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorPhilip Goto2021-04-15 11:40:08 +0200
committerPhilip Goto2021-04-15 11:40:08 +0200
commitb4328656b836dca6c2eb7fee9410b35af73e6db7 (patch)
tree6d39df1428557b4db30d6f22565e16cbdda6a5b3 /PKGBUILD
downloadaur-b4328656b836dca6c2eb7fee9410b35af73e6db7.tar.gz
Initialize
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD34
1 files changed, 34 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..dd8a1e8fd168
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: Philip Goto <philip.goto@gmail.com>
+
+pkgname=gtksourceview5
+pkgver=5.0.0
+pkgrel=1
+pkgdesc="A text widget adding syntax highlighting and more to GNOME"
+url="https://gitlab.gnome.org/GNOME/gtksourceview"
+license=("LGPL")
+arch=(i686 x86_64 armv7h aarch64)
+depends=(gtk4)
+makedepends=(
+ git
+ gobject-introspection
+ meson
+ vala
+)
+checkdepends=(xorg-server-xvfb)
+source=("git+https://gitlab.gnome.org/GNOME/gtksourceview.git#tag=${pkgver}")
+sha256sums=('SKIP')
+
+build() {
+ arch-meson gtksourceview build -D gtk_doc=true
+ meson compile -C build
+}
+
+check() {
+ dbus-run-session xvfb-run \
+ -s '-screen 0 1920x1080x24 -nolisten local' \
+ meson test -C build --print-errorlogs
+}
+
+package() {
+ DESTDIR="${pkgdir}" meson install -C build
+}