summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorRafael Fontenelle2018-11-05 21:25:09 -0200
committerRafael Fontenelle2018-11-05 21:25:09 -0200
commit72dbb10138876fcf16843728723a9c1d8cc1af21 (patch)
tree94efe98c684819b8d2692fb25e2dd5c6e11ef442 /PKGBUILD
downloadaur-72dbb10138876fcf16843728723a9c1d8cc1af21.tar.gz
Initial commit
Version 3.31.0, development version
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD36
1 files changed, 36 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b59ca36982af
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# Maintainer: Rafael Fontenelle <rafaelff@gnome.org>
+
+_name=gtranslator
+pkgname=$_name-git
+pkgver=3.31.0.r4732.cdef36e7
+pkgrel=1
+pkgdesc='Translation Editor, an Enhanced gettext po file editor for the GNOME'
+arch=('x86_64')
+url='http://projects.gnome.org/gtranslator/'
+license=('GPL')
+depends=(gtksourceview4 gspell gettext libgda)
+makedepends=(meson gobject-introspection git gtk-doc yelp-tools)
+conflicts=($_name)
+provides=($_name)
+source=("git+https://gitlab.gnome.org/GNOME/$_name")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd $_name
+ v=$(grep -R '^ version:' meson.build | cut -d\' -f2)
+ printf "$v.r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+prepare() {
+ rm -rf build
+ mkdir build
+}
+
+build() {
+ meson --prefix /usr --buildtype=plain -Dgtk_doc='true' $_name build
+ ninja -C build
+}
+
+package() {
+ DESTDIR="$pkgdir" ninja -C build install
+}