summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJoan Figueras2017-05-09 17:55:47 +0200
committerJoan Figueras2017-05-09 17:55:47 +0200
commit9067d9ff8af863d0ed82c0d3ba919066b8625da1 (patch)
tree55b4a6d76fa6c9fc555104e48d064b5bc3467f5f /PKGBUILD
parent1f82fef9b892b69f000c7aae1c660cd64df0b8ee (diff)
downloadaur-9067d9ff8af863d0ed82c0d3ba919066b8625da1.tar.gz
Rebuild against openssl-1.0. Also, removed freerdp dependency for now, it is completely broken
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD9
1 files changed, 6 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 4ccd71c442e4..b0def018fac5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,14 +3,14 @@
pkgname=guacamole-server
pkgver=0.9.12
-pkgrel=1
+pkgrel=2
pkgdesc="Guacamole proxy daemon"
arch=('i686' 'x86_64')
url="http://guacamole.sourceforge.net/"
license=('GPL3')
replaces=('guacd' 'libguac' 'libguac-client-ssh' 'libguac-client-vnc' 'libguac-client-rdp')
depends=('pango' 'openssl' 'libvorbis' 'uuid' 'libwebp')
-makedepends=('libpulse' 'libvorbis' 'openssl' 'libssh' 'libvncserver' 'pango' 'libtelnet' 'freerdp')
+makedepends=('libpulse' 'libvorbis' 'openssl-1.0' 'libssh' 'libvncserver' 'pango' 'libtelnet')
optdepends=('libssh: for ssh protocol support'
'libvncserver: for vnc protocol support'
'freerdp: for rdp protocol support'
@@ -25,7 +25,10 @@ md5sums=('23f44726590ae6827f58d25b8c91663a'
build() {
cd "$srcdir"/$pkgname-$pkgver-incubating
- ./configure --prefix=/usr --sbindir=/usr/bin CPPFLAGS="-Wno-error=pedantic -Wno-deprecated-declarations"
+ PKG_CONFIG_PATH=/usr/lib/openssl-1.0/pkgconfig \
+ CFLAGS+=" -I/usr/include/openssl-1.0" \
+ LDFLAGS+=" -L/usr/lib/openssl-1.0 -lssl" \
+ ./configure --with-openssl --prefix=/usr --sbindir=/usr/bin CPPFLAGS="-Wno-error=pedantic"
make
}