summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMiguel Angel Useche Castro2018-01-07 23:18:25 -0400
committerMiguel Angel Useche Castro2018-01-07 23:18:25 -0400
commitc3fe77ceedcd27551d78f6be57c406070f973ba4 (patch)
tree9e63c4f789ed529aa0afd9c40db6c322637a867d /PKGBUILD
downloadaur-c3fe77ceedcd27551d78f6be57c406070f973ba4.tar.gz
Adding gtk2 version of the package
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD35
1 files changed, 35 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..95e254515429
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: Miguel Useche <migueluseche@skatox.com>
+# Contributor: Anton Leontiev <unsector /at/ km.ru>
+# Contributor: Sandy Carter <bwrsandman /at/ gmail.com>
+
+pkgname=guake-gtk2-git
+_appname=guake
+pkgver=0.8.12
+pkgrel=1
+pkgdesc="Top-down terminal for Gnome"
+arch=('i686' 'x86_64' 'armv7h')
+url="https://github.com/Guake/guake"
+license=('GPL')
+depends=('python2' 'pygtk' 'python2-dbus' 'python2-gconf' 'python2-keybinder2' 'python2-notify' 'vte' 'python2-xdg' 'libutempter' 'pkgconfig' 'gtk2' 'glib2')
+makedepends=('git' 'intltool' 'gnome-common' 'python2-gconf')
+conflicts=('guake')
+provides=('guake')
+source=("git://github.com/Guake/guake.git#branch=0.8.x")
+sha512sums=('SKIP')
+install=guake.install
+
+pkgver() {
+ cd "${srcdir}/${_appname%-git}"
+ git describe --tags | sed 's,-,.,g'
+}
+
+build(){
+ cd "${srcdir}/${_appname%-git}"
+ PYTHON=$(which python2) ./autogen.sh --prefix=/usr --sysconfdir=/usr/share --disable-static
+ make
+}
+
+package() {
+ cd "${srcdir}/${_appname%-git}"
+ make GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1 DESTDIR="$pkgdir" install
+}