summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorFabioLolix2023-02-20 21:50:32 +0100
committerFabioLolix2023-02-20 21:50:32 +0100
commitaad63bc3a5292144b193c8e32ae8f197dc0c2396 (patch)
tree13ff7091232b31100b0799c542fe56b6c7f382d7 /PKGBUILD
parent5069ed1ec6ba05aa08535d1eb650920edbb3e148 (diff)
downloadaur-aad63bc3a5292144b193c8e32ae8f197dc0c2396.tar.gz
v0.4.7
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD23
1 files changed, 10 insertions, 13 deletions
diff --git a/PKGBUILD b/PKGBUILD
index da279a5781c5..9e8691272d47 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,26 +7,26 @@
# Contributor: Michael Straube <straubem@gmx.de>
pkgname=guayadeque
-pkgver=0.4.6
-pkgrel=2
+pkgver=0.4.7
+pkgrel=1
pkgdesc="Lightweight music player"
-arch=(i686 x86_64)
-url="http://guayadeque.org/"
+arch=(x86_64)
+url="https://guayadeque.org/"
license=(GPL3)
-depends=(wxsqlite3 wxgtk3 webkit2gtk taglib gst-plugins-base gst-plugins-good)
+depends=(wxsqlite3 wxwidgets-gtk3 webkit2gtk taglib gst-plugins-base gst-plugins-good)
makedepends=(cmake)
optdepends=('gst-libav: additional codecs'
'gst-plugins-bad: additional codecs'
'gst-plugins-ugly: additional codecs')
source=("${pkgname}-${pkgver}.tar.gz::https://github.com/anonbeat/guayadeque/archive/v${pkgver}.tar.gz"
- "https://github.com/anonbeat/guayadeque/commit/6be35ba2153f1c36400b8c535d8ba49292a1f51e.diff")
-sha256sums=('3c0d782c6f4aa511c7a635a78742542d130d1a13e20648db886ccfce4e1b9d4f'
- 'ac536bb3aa23fedd7634b31dbb309c0e130c5bd1a3bfbbab096bcc897091363a')
+ "https://github.com/sluedecke/guayadeque/commit/a9ecb9d8bf785281ed8ccf292cccf3525ffeb457.patch")
+sha256sums=('38d6ab8a1820e8c205b8f07d86fee912263dfdb982f5c08086e897600e0771b2'
+ '046883477c149fb78668285cbd7293be343adc3010631ff55ab2eae2dc2d12e0')
prepare() {
cd "${srcdir}/${pkgname}-${pkgver}"
install -d build-guayadeque
- patch -Np1 -i ../6be35ba2153f1c36400b8c535d8ba49292a1f51e.diff
+ patch -Np1 -i ../a9ecb9d8bf785281ed8ccf292cccf3525ffeb457.patch
}
build() {
@@ -36,10 +36,7 @@ build() {
-DCMAKE_BUILD_TYPE=Release \
-DCMAKE_INSTALL_PREFIX=/usr \
-D_GUREVISION_:STRING="${pkgrel}" \
- -DCMAKE_EXE_LINKER_FLAGS=-lwx_gtk3u_aui-3.0 \
- -DwxWidgets_wxrc_EXECUTABLE=/usr/bin/wxrc-3.0 \
- -DwxWidgets_CONFIG_EXECUTABLE=/usr/bin/wx-config-gtk3 \
- -DwxWidgets_INCLUDE_DIRS=/usr/include/wx-3.0
+ -DwxWidgets_CONFIG_EXECUTABLE=/usr/bin/wx-config
make
}