summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorPaco Pascal2023-03-11 17:39:03 -0500
committerPaco Pascal2023-03-11 17:39:03 -0500
commit3c72f586e81bb49baf8901e32ae8c72a712441f9 (patch)
tree085aed729d21049d14d71176789bf635f6ccf040 /PKGBUILD
downloadaur-3c72f586e81bb49baf8901e32ae8c72a712441f9.tar.gz
init
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD38
1 files changed, 38 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..00b991e1858c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,38 @@
+# Maintainer: Paco Pascal <me@pacopascal.com>
+# Contributor: Jelle van der Waa <jelle@archlinux.org>
+# Contributor: lantw44 (at) gmail (dot) com
+
+_checkoutdir='scheme-bytestructures'
+_pkgname='guile-bytestructures'
+pkgname="${_pkgname}-git"
+pkgver=latest
+pkgrel=1
+pkgdesc='Structured access library to bytevector contents for Guile.'
+arch=('any')
+url='https://github.com/TaylanUB/scheme-bytestructures'
+license=('GPL3')
+options=('!strip')
+depends=('guile')
+makedepends=('autoconf' 'automake')
+conflicts=("${pkgname%-git}")
+provides=("${pkgname%-git}")
+source=('git+https://github.com/TaylanUB/scheme-bytestructures.git')
+md5sums=('SKIP')
+
+prepare() {
+ cd "${_checkoutdir}"
+ aclocal
+ autoconf
+ automake --add-missing
+}
+
+build() {
+ cd "${_checkoutdir}"
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd "${_checkoutdir}"
+ make DESTDIR="${pkgdir}" install
+}