summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorStefan Husmann2016-09-05 23:32:26 +0200
committerStefan Husmann2016-09-05 23:32:26 +0200
commit969a0a385e736d82fad6c8439e2f396f366d5f89 (patch)
tree92c250b45c41b502b1eb13803bdd6d622d98f7f2 /PKGBUILD
parent34adc3f9cfa1cdeac8457c4872659b7d4176378f (diff)
downloadaur-969a0a385e736d82fad6c8439e2f396f366d5f89.tar.gz
compilex only with clang now.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD31
1 files changed, 24 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 9c6941ef8ea2..6592e1621463 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Stefan Husmann <stefan-husmann@t-online.de>
pkgname=guile-emacs-git
pkgver=116892.41120e0
-pkgrel=3
+pkgrel=4
pkgdesc="branch of GNU Emacs that replaces Emacs' own EmacsLisp engine with that of Guile."
arch=('i686' 'x86_64')
url="http://www.emacswiki.org/emacs/GuileEmacs"
@@ -11,8 +11,8 @@ makedepends=('git')
conflicts=('emacs' 'ctags')
provides=('emacs' 'ctags')
options=('!strip' '!makeflags')
-source=("guilemacs::git://git.hcoop.net/git/bpt/emacs.git#branch=wip")
-md5sums=('SKIP')
+source=("guilemacs::git://git.hcoop.net/git/bpt/emacs.git#branch=wip" )
+sha256sums=('SKIP')
_gitname="guilemacs"
pkgver() {
@@ -20,14 +20,31 @@ pkgver() {
printf "%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
+prepare() {
+ cd "$srcdir/$_gitname"
+ [[ -x configure ]] || ./autogen.sh
+}
+
build() {
cd "$srcdir"/"$_gitname"
- ./autogen.sh
- ./configure --prefix=/usr \
+ # Avoid hardening-wrapper (taken from emacs-pretest, thanks to Thomas Jost).
+ export PATH=$(echo "$PATH" | sed 's!/usr/lib/hardening-wrapper/bin!!g')
+
+ CC=clang ./configure --prefix=/usr \
+ --sysconfdir=/etc \
--localstatedir=/var \
--libexecdir=/usr/lib \
- --with-jpeg=no
- make
+ --with-jpeg=no \
+ --mandir=/usr/share/man \
+ --with-gameuser=:games \
+ --with-sound=alsa \
+ --with-xft \
+ --with-modules \
+ --with-x-toolkit=gtk3 \
+ --without-gconf \
+ --with-gsettings
+
+ make
}
package() {