summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAUR Update Bot2015-12-17 04:03:43 +0100
committerStefan Husmann2015-12-17 04:03:43 +0100
commitd62d792ce0cbf458b6f2e0183ba6f4b3eb8c1840 (patch)
treec6785a49dcab3992e3c789d58c77c9cf2992c825 /PKGBUILD
parenta20f04284fececf08ebe9f7253c947043d94725c (diff)
downloadaur-d62d792ce0cbf458b6f2e0183ba6f4b3eb8c1840.tar.gz
Updated version (2.1.1.75.ga1471e0 -> 2.1.1.76.g3c27145).
Changelog ========= Fix build when threads are disabled (3c27145) Add another simplification pass to make rotate-loops work better (a1471e0) Add support for comparing u64 values with SCM values (1d4b4ec) Small VM cleanups (97755a1) Refactor range checking in assembler instruction packers (7a43a3a) Add ursh/immediate and ulsh/immediate ops (9514dc7) Assembler has a single growable vector (2468871) More efficient assembler instructions (dbd9265) Specialize u64 bit operations (73065c7) Add untagged bitwise operations (3d6dd2f) Disable warnings on bootstrap build (eb86afc) Add logsub op. (8208525) Add current-thread VM op (8c75a5e) Unbox indexes of vectors, strings, and structs (c3240d0) Untag values and indexes for all bytevector instructions (a08b3d4) Add support for unboxed s64 values (8bf77f7) New instructions load-f64, load-u64 (f34688a) Add tagged and untagged arithmetic ops with immediate operands (bdfa1c1) Remove add1 and sub1 (8f18b71) Specialize u64 arithmetic (e003466) Better range inference for indexes of vector-ref, string-ref et al (d2808b1) Slower range saturation in type inference (6728536) Add unsigned 64-bit arithmetic operators: uadd, usub, umul (d294d5d) Unbox u64 phi values (2906d96) Beginning of u64 phi unboxing (4305b39) Specialize u64 comparisons (163fcf5) Add instructions to branch on u64 comparisons (07607f6) bv-f{32,64}-{ref,set!} take unboxed u64 index (87cc8b0) Add bv-length instruction (8464cc5) Range inference over the full U64+S64 range (870ac91) Remove frame->module (a7e1c39) Add low-level support for unboxed 64-bit unsigned ints (dfbe869) Remove frame-procedure (58153e3) VM traps don't match on value of slot 0 (3582787) Remove `procedure' repl command (adb2329) ,registers doesn't use frame-procedure (2d0214a) Better frame-call-representation printing of GC clobbers (c960c76) More robust low-level frame printer (9a8c299) frame-call-representation avoids frame-procedure. (029af6f) Add frame-procedure-name (39090e6) Remove primitive?, add primitive-code? (8af3423) Apply of non-programs has IP that is not from prev frame (3b3405e) All arities serialize a "closure" binding (e5d7c0f) Identify boot continuations by code, not closure (02fc5a7) Remove br-if-equal opcode (d729a0d) Don't compile equal? to br-if-equal (3e5d413) Fix miscompilation of closures allocated as vectors (92ed7f6) load-path will skip over stale .go files and keep going (13edcf5) Eval speedup for lexical-ref (25738ec) Bump bytecode version (ac5a05d) Remove debug printout in specialize-numbers (7dc3e4b) Better f64 unboxing for loop vars that might flow to $ktail (80f2726) The compiler can unbox float64 loop variables (5b9835e) Fix slot representation computation for fadd, fmul, etc (f0594be) Add new pass to specialize "add" into "fadd" where possible (12e9e21) Add fadd, fsub, fmul, fdiv instructions (3b4941f) Scalar replacement for f64->scm (c438998) bv-{f32,f64}-{ref,set!} operate on raw f64 values (b1ac8d6) Type inference distinguishes between untagged and tagged flonums (6087539) Add VM ops to pack and unpack raw f64 values. (5bbc47b) Stack slots can hold a double (fc87033) Reflection support for unboxed f64 slots (e3cc0ee) VM support for raw slots (e7660a6) Treat tail $values as generating lazy allocations (dd77a81) Remove return opcode (9585508) Remove use of return in disassembler.scm (c984432) rtl.test uses return-values (8db54c8) Always emit return-values (696339a) Replace return primcalls with $values (2f08838) Don't emit redundant reset-frame before return (7c9e477) return-values opcode resets the frame (7aee3c7) Fix slot-allocation to make 'return' not need to alloc-frame (34f3fb7) Run CSE to clean up after closure conversion (3f345f5) CSE can run on first-order CPS (04356da) Revert "Bootstrap build doesn't have to expand CPS optimizations" (8d79dfd) Bootstrap build doesn't have to expand CPS optimizations (ce36fb1)
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD2
1 files changed, 1 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 0e0936e8e759..5b0b05c6c6d0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=guile-git
_gitname=guile
-pkgver=2.1.1.75.ga1471e0
+pkgver=2.1.1.76.g3c27145
pkgrel=1
pkgdesc="A portable, embeddable Scheme implementation (Git snapshot)"
arch=('i686' 'x86_64')