summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJaume Delclòs Coll2016-07-10 23:18:23 +0200
committerJaume Delclòs Coll2016-07-10 23:18:23 +0200
commit7c56e35fbacf6592bcbf5a81c8bc2f7d52b3c7f8 (patch)
treee6f752caa764d184f401543fcfcb801cc71617a0 /PKGBUILD
parent9e5e1238d75c44b5069fcef34a10480122c1ea95 (diff)
downloadaur-7c56e35fbacf6592bcbf5a81c8bc2f7d52b3c7f8.tar.gz
update and simplify
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD31
1 files changed, 8 insertions, 23 deletions
diff --git a/PKGBUILD b/PKGBUILD
index c753bfa1268d..6b17f354e1e4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,41 +2,26 @@
# Contributor: Daniel Krueger <keenbug gmail.com>
# Contributor: Daniel Oliveira <psykond@gmail.com>
pkgname=guile-gnome-platform
-_pkgname=guile-gnome
-pkgver=2.16.3
+pkgver=2.16.4
pkgrel=1
-epoch=1
pkgdesc="Binding between Guile Scheme and the Gnome stack of libraries. (fe. Pango, GTK+, Cairo, GStreamer, Glade, GtkSourceView and else). To build wrappers for GTK+ and higher in the stack, you will first need Guile-Cairo."
arch=('i686' 'x86_64')
url="http://www.gnu.org/software/guile-gnome/"
license=('GPL2')
depends=('g-wrap' 'guile-cairo' 'libgnomeui')
-makedepends=('gcc49')
provides=($pkgname)
conflicts=($pkgname)
-install=guile-gnome-platform.install
options=(!libtool)
-# once it's available, switch to this url
-#source=("http://ftp.gnu.org/pub/gnu/guile-gnome/$pkgname/$pkgname-$pkgver.tar.gz")
-source=("http://git.savannah.gnu.org/cgit/guile-gnome.git/snapshot/guile-gnome-$pkgver.tar.gz")
-md5sums=('0f48e1a90c72d813e47b567e03264ac1')
-
-pkgver() {
- cd $_pkgname-$pkgver
- git describe --long --tags | sed -E 's,^[^0-9]*,,;s,([^-]*-g),r\1,;s,-,.,g'
-}
-
-prepare() {
- cd $_pkgname-$pkgver
- ./autogen.sh --prefix=/usr
-}
+source=("http://ftp.gnu.org/pub/gnu/guile-gnome/$pkgname/$pkgname-$pkgver.tar.gz")
+md5sums=('930178554957a25209c6ca0adeb3a584')
build() {
- cd $_pkgname-$pkgver
- CC=gcc-4.9 ./configure --prefix=/usr
+ cd $pkgname-$pkgver
+ ./configure --prefix=/usr
make
}
-package() {
- cd $_pkgname-$pkgver
+
+package() {
+ cd $pkgname-$pkgver
make DESTDIR="$pkgdir/" install
}