summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorhaawda2017-05-30 00:07:24 +0200
committerhaawda2017-05-30 00:07:24 +0200
commit3d537dabff933ea86eea5e025b4d2c180c1846a8 (patch)
tree1829d900c9bc314f22e15a4bd1be45e15c1457b3 /PKGBUILD
parent851bd632b6a0fd9105996774c93f5b73ea7ddb66 (diff)
downloadaur-3d537dabff933ea86eea5e025b4d2c180c1846a8.tar.gz
fix PKGBUILD to really download the most recent sources, new pkgver function
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD7
1 files changed, 4 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 2c08ef248c61..9b4230c16b36 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: Stefan Husmann <stefan-husmann@t-online.de>
pkgname=guile-wm-git
-pkgver=20170507.be8b6d1
+pkgver=1.0.6.gf3c7b3b
pkgrel=1
pkgdesc="Windowmanagement environment for guile"
arch=('any')
@@ -10,13 +10,14 @@ depends=('guile' 'guile-xcb')
makedepends=('git')
provides=('guile-wm')
conflicts=('guile-wm')
-source=("git+https://github.com/mwitmer/guile-wm")
+source=("git+https://github.com/mwitmer/guile-wm.git")
md5sums=('SKIP')
options=('!makeflags')
_gitname="guile-wm"
pkgver() {
- git log -1 --format='%cd.%h' --date=short | tr -d -
+ cd $_gitname
+ printf %s $(git describe --tags | tr - .)
}
prepare() {