summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAlexander Minges2016-01-12 03:59:08 +0100
committerAlexander Minges2016-01-12 03:59:08 +0100
commit92ea630ca02e16a28df85263635fad50640d6bdd (patch)
tree80276159e8059a56c9619a98249a17994344aaef /PKGBUILD
downloadaur-92ea630ca02e16a28df85263635fad50640d6bdd.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD47
1 files changed, 47 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ba90e176a6bc
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,47 @@
+# Maintainer: Alexander Minges <alexander.minges@gmail.com>
+# Contributor: Tom Newsom <Jeepster@gmx.co.uk>
+# Former Maintainer: Jan de Groot <jgc@archlinux.org>
+# Current Contributor: Patrick McCarty <pnorcks at gmail dot com>
+
+pkgname=guile1.8-gtk
+_pkgname=guile-gtk
+pkgver=2.1
+pkgrel=3
+pkgdesc="Guile (Scheme) bindings for GTK+"
+arch=('i686' 'x86_64')
+url="http://www.nongnu.org/guile-gtk/"
+license=('GPL')
+depends=('guile>=1.8.1' 'gtk2' 'gtkglarea')
+options=('!makeflags')
+source=(ftp://ftp.gnu.org/gnu/${_pkgname}/${_pkgname}-${pkgver}.tar.gz deprecated.patch
+ brokentest.patch
+ g-object-ref.diff
+ prll-install.patch
+ guile1.8.patch)
+md5sums=('4ed9b00f4cefdef412923270d8ad02a5'
+ 'f1e28215b95c0bf10eacd8dacb6f2d55'
+ 'edfde0720a7b2f70f2d15aaca72dc704'
+ '191a9979bf975c30169247ab685cabc8'
+ 'be846cdb7eac97495b4fa6ae23a624d1'
+ '7d70c49c4f0565b270863038ab9f5919')
+
+build() {
+ cd ${srcdir}/${_pkgname}-${pkgver}
+ patch -Np1 -i ../deprecated.patch
+ patch -Np1 -i ../brokentest.patch
+ patch -Np1 -i ../prll-install.patch
+ patch -Np1 -i ../guile1.8.patch
+
+ #aclocal
+ # libtoolize --automake --copy
+ #autoconf
+ #automake --copy --add-missing --gnu
+
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd ${srcdir}/${_pkgname}-${pkgver}
+ make DESTDIR="${pkgdir}" install
+}