summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorhaawda2017-03-24 05:38:51 +0100
committerhaawda2017-03-24 05:38:51 +0100
commit34d7f116b2f2a53d17e187a49a8f5aec52a2d30a (patch)
treebf49fd747b1fc724538e94e190ea6f172afd54fe /PKGBUILD
parentd36db07dafe994ca11557d4b48915276be08eb86 (diff)
downloadaur-guile4emacs-git.tar.gz
add openmp as makedep
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD8
1 files changed, 4 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index d20be2da7e86..512f56a498bd 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,13 +3,13 @@
pkgname=guile4emacs-git
_gitname="guile"
pkgver=r17564.15ca78482
-pkgrel=1
+pkgrel=2
pkgdesc="patched version of guile for guile-emacs"
arch=('i686' 'x86_64')
url="http://www.emacswiki.org/emacs/GuileEmacs"
license=('GPL')
depends=('gmp' 'gc' 'bash' 'libffi' 'libunistring' 'libltdl')
-makedepends=('git')
+makedepends=('git' 'clang' 'openmp')
conflicts=('guile-git')
provides=('guile-git')
options=('!strip' '!makeflags')
@@ -24,8 +24,8 @@ pkgver() {
build() {
cd "$srcdir"/"$_gitname"
./autogen.sh
- ./configure --prefix=/usr --disable-error-on-warning \
- --program-suffix=-4emacs
+ CC=clang ./configure --prefix=/usr --disable-error-on-warning \
+ --program-suffix=4emacs
make
}