summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorGimmeapill2020-01-26 17:18:32 +0100
committerGimmeapill2020-01-26 17:18:32 +0100
commit7ddd86fda45282011801fedda173645d62867123 (patch)
tree74cc172f55d81229399e81e957d534022961726a /PKGBUILD
parent23de325bc7f7d315a88aaedfb8e2a8bd1bdbc6d4 (diff)
downloadaur-7ddd86fda45282011801fedda173645d62867123.tar.gz
dependencies and build flags updates
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD16
1 files changed, 8 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 0be27211d4de..3f7dd7dd1b8e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,17 +7,16 @@
pkgname=guitarix-git
pkgver=0.39.0.r5.g2addb8b8
pkgrel=1
-pkgdesc="A simple mono guitar amplifier and FX for JACK using Faust"
+pkgdesc="virtual guitar amplifier for Jack/Linux"
arch=('x86_64')
url="https://guitarix.org"
license=('GPL3')
groups=('ladspa-plugins' 'lv2-plugins' 'pro-audio')
-depends=('avahi' 'bluez-libs' 'cairo' 'cairomm' 'gcc-libs' 'gdk-pixbuf2'
-'glib2' 'glibc' 'glibmm' 'gtk2' 'gtkmm' 'libboost_iostreams.so' 'libcurl.so'
-'libjack.so' 'liblilv-0.so' 'liblrdf.so' 'libsndfile.so' 'libzita-convolver.so'
-'libzita-resampler.so' 'pango' 'pangomm' 'ttf-roboto')
+depends=('jack' 'gtkmm' 'liblrdf' 'lilv' 'bluez-libs' 'boost-libs'
+'zita-convolver' 'zita-resampler' 'ttf-roboto' 'libsndfile')
makedepends=('git' 'boost' 'eigen' 'gperf' 'intltool' 'ladspa' 'lv2' 'waf')
-provides=('libgxw.so' 'libgxwmm.so')
+provides=('guitarix' 'libgxw.so' 'libgxwmm.so')
+conflicts=('guitarix')
replaces=('guitarix2')
source=("${pkgname%-*}::git+https://git.code.sf.net/p/guitarix/git")
md5sums=('SKIP')
@@ -29,10 +28,11 @@ pkgver() {
build() {
cd "${pkgname%-*}/trunk"
- # when building with faust 2.20.2 it fails: https://sourceforge.net/p/guitarix/bugs/86/
waf configure --prefix=/usr \
+ --optimization \
+ --includeresampler \
+ --includeconvolver \
--enable-nls \
- --ladspa \
--new-ladspa \
--no-faust \
--shared-lib \