summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorGimmeapill2023-01-22 18:54:59 +0100
committerGimmeapill2023-01-22 18:54:59 +0100
commit280b3a2e06a0fa9db5ad72e9d6949b2fa9c01cd9 (patch)
treecadb6ee8efb77d30af8357765a56823c9af76f63 /PKGBUILD
downloadaur-280b3a2e06a0fa9db5ad72e9d6949b2fa9c01cd9.tar.gz
Initial import
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD33
1 files changed, 33 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9748af2e7a51
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Gimmeapill <gimmeapill at gmail dot com>
+
+pkgname=guitarix.vst-git
+pkgver=Latest.r0.g6bd494c
+pkgrel=1
+pkgdesc="virtual versatile amplification for Jack/Linux - vst3 wrapper"
+arch=('x86_64')
+url="https://github.com/brummer10/guitarix.vst"
+license=('GPL3')
+groups=('vst-plugins' 'pro-audio')
+depends=('guitarix' 'jack' 'gtkmm3' 'liblo' 'liblrdf' 'libsndfile' 'lilv' 'bluez-libs' 'boost-libs'
+'zita-convolver' 'zita-resampler' 'ttf-roboto')
+makedepends=('git' 'boost' 'eigen' 'gperf' 'intltool' 'ladspa' 'lv2' 'waf' 'sassc' 'pkgconfig' 'webkit2gtk')
+provides=('guitarix.vst')
+source=("${pkgname%-*}::git+https://github.com/brummer10/guitarix.vst")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "${pkgname%-*}"
+ git describe --long --tags | sed -r 's/^V//;s/([^-]*-g)/r\1/;s/-/./g'
+}
+
+build() {
+ cd "$srcdir/${pkgname%-*}"
+ git submodule init
+ git submodule update
+ make
+}
+
+package() {
+ cd "$srcdir/${pkgname%-*}"
+ make JUCE_VST3DESTDIR="$pkgdir/usr/lib/vst3/" install
+}