summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorTing-Wei Lan2014-04-18 00:29:15 +0800
committerTing-Wei Lan2014-04-18 01:00:33 +0800
commit02e6e46e61cf445e465537b44f5aafab5bd69561 (patch)
tree0bf957197b5764677e365bc91b3596369510dcba /PKGBUILD
parent107c1fdea6d19a8a2a9e43643934d0bf32262c9c (diff)
downloadaur-02e6e46e61cf445e465537b44f5aafab5bd69561.tar.gz
guix: Add a systemd service file
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD13
1 files changed, 10 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index e158fa494f7e..2cc134bd5229 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,15 +3,19 @@
pkgname=guix
pkgver=0.6
-pkgrel=1
+pkgrel=2
pkgdesc="GNU guix is a purely functional package manager"
arch=('x86_64' 'i686')
url="https://www.gnu.org/software/guix/"
license=('GPL')
depends=('guile>=2.0.5' 'sqlite>=3.6.19' 'bzip2' 'libgcrypt')
makedepends=()
-source=("ftp://alpha.gnu.org/gnu/${pkgname}/${pkgname}-${pkgver}.tar.gz")
-md5sums=('1315c0c5be660dbfe388385be5a8b011')
+source=(
+"ftp://alpha.gnu.org/gnu/${pkgname}/${pkgname}-${pkgver}.tar.gz"
+"guix.service")
+md5sums=(
+'1315c0c5be660dbfe388385be5a8b011'
+'4e088207919bdefff13a9d452f79467b')
build() {
current_arch="`uname -m`"
@@ -29,5 +33,8 @@ check() {
package() {
cd ${srcdir}/${pkgname}-${pkgver}
make DESTDIR="${pkgdir}" install
+ mkdir -p ${pkgdir}/lib/systemd/system
+ install -m 644 "${srcdir}/guix.service" \
+ ${pkgdir}/lib/systemd/system/guix.service
chmod -R u+w test-tmp
}