summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorTing-Wei Lan2022-03-14 18:05:54 +0800
committerTing-Wei Lan2022-03-14 18:05:54 +0800
commit06b3bedf22151d900bf477558113fb6ece988184 (patch)
tree932bed11d4213e17f4f2a34b5cbb8a5fe58c1c67 /PKGBUILD
parent69f5029ab93aa57adddd6452212e015520bdc2cb (diff)
downloadaur-06b3bedf22151d900bf477558113fb6ece988184.tar.gz
guix: Ignore tidy_strip error
It can return a non-zero value even if it succeeds. https://aur.archlinux.org/packages/guix#comment-851788
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD5
1 files changed, 4 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 1a76aca7a3f6..7fa69b3a1d60 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -140,6 +140,9 @@ package() {
# put in eval.
eval 'options=()'
cd "${pkgdir}/usr/bin"
- tidy_strip
+ # tidy_strip may exit with a non-zero return value even if all operations
+ # are successful. Therefore, we have to ignore its return value to prevent
+ # makepkg from reporting it as an error.
+ tidy_strip || true
eval 'options=("!strip")'
}