summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorTing-Wei Lan2016-08-11 01:21:39 +0800
committerTing-Wei Lan2016-08-11 02:05:35 +0800
commit44e0f7c33fa67045bddd4856766bd57961fb8ef5 (patch)
tree98f41b1297c801c2ec866c01e27d2a025ad4293a /PKGBUILD
parentae503e5ca998ce4c53205aee9df91c60911e9530 (diff)
downloadaur-44e0f7c33fa67045bddd4856766bd57961fb8ef5.tar.gz
guix: Don't strip binaries installed in gnu/packages/bootstrap/*
These binaries must be copied without any modification because all packages built by guix depend on them. If they are stripped, users cannot use prebuilt packages provided by hydra.gnu.org, which is inconvenient and unexpcted. This commit also adds zlib to depends, as it is needed by guix/zlib.scm. Although it is not required to do so because other dependent packages pull it in, it is still better to explicitly list required dependencies.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD20
1 files changed, 18 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 392765c1a7bf..eb86fe11420f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,11 +7,12 @@
pkgname=guix
pkgver=0.11.0
-pkgrel=1
+pkgrel=2
pkgdesc="A purely functional package manager for the GNU system"
arch=('x86_64' 'i686')
url="https://www.gnu.org/software/guix/"
license=('GPL')
+options=('!strip')
makedepends=(
'bash-completion'
'emacs' # Please remove this if you are not going to use guix in emacs
@@ -23,7 +24,8 @@ depends=(
'sqlite>=3.6.19'
'bzip2'
'gnutls'
- 'libgcrypt')
+ 'libgcrypt'
+ 'zlib')
optdepends=(
'bash-completion: to enable bash programmable completion'
'emacs: to enable Emacs Interface'
@@ -63,4 +65,18 @@ package() {
make DESTDIR="${pkgdir}" install
# Remove the unused upstart service file
rm -r ${pkgdir}/usr/lib/upstart
+ # The default makepkg strip option cannot be used here because binaries
+ # installed in /usr/share must not be stripped.
+ # To keep user-defined 'strip' and 'debug' options useful, we still
+ # depend on 'tidy_strip' function provided by makepkg to do the stripping
+ # work. To make the function useful, we have to temporarily remove the
+ # '!strip' option from 'options' array. However, assignments to 'options'
+ # cause mksrcinfo to insert wrong lines to .SRCINFO, so they have to be
+ # put in eval.
+ eval 'options=()'
+ cd ${pkgdir}/usr/bin
+ tidy_strip
+ cd ${pkgdir}/usr/lib
+ tidy_strip
+ eval 'options=("!strip")'
}