summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorTing-Wei Lan2016-11-04 20:08:27 +0800
committerTing-Wei Lan2016-11-04 20:14:56 +0800
commit8505f1dcae994234a6db2ab3719273539013ddc7 (patch)
tree2388a117293fd4023ac3b5a3b22560ea8e01d4be /PKGBUILD
parent505b2a769e120a6bca18d847f1a8737cd9715a3a (diff)
downloadaur-8505f1dcae994234a6db2ab3719273539013ddc7.tar.gz
guix: Fix build failure with Guile 2.0.13
Reported by rafaelff on AUR at 2016-11-01 15:36: https://aur.archlinux.org/packages/guix/?comments=all
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD18
1 files changed, 15 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 302d952c1638..ba86e191420a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,7 +7,7 @@
pkgname=guix
pkgver=0.11.0
-pkgrel=2
+pkgrel=3
pkgdesc="A purely functional package manager for the GNU system"
arch=('x86_64' 'i686')
url="https://www.gnu.org/software/guix/"
@@ -32,12 +32,24 @@ optdepends=(
'graphviz: to enable Emacs Interface'
'guile-json: to import packages from cpan, gem, pypi')
source=(
- "ftp://alpha.gnu.org/gnu/${pkgname}/${pkgname}-${pkgver}.tar.gz"{,.sig})
+ "ftp://alpha.gnu.org/gnu/${pkgname}/${pkgname}-${pkgver}.tar.gz"{,.sig}
+ "guix-guile-2.2-compat.patch"
+ "guix-delete-go-files-SIGINT.patch")
install="${pkgname}.install"
sha1sums=('bd12d65a46c8eef3b490efea6ac953b995d524eb'
- 'a9080412df96832d22e57a1bcc76e3016f93f0b0')
+ 'a9080412df96832d22e57a1bcc76e3016f93f0b0'
+ '0b976fe5862798b34fdb90d9f9f405b39ccedb1b'
+ '3506f8bb7cf35776739a6cc1afceff31555cebc0')
validpgpkeys=('3CE464558A84FDC69DB40CFB090B11993D9AEBB5')
+prepare() {
+ cd ${srcdir}/${pkgname}-${pkgver}
+ # http://git.savannah.gnu.org/cgit/guix.git/commit/?id=5a88b2d
+ patch -Np1 < "${srcdir}/${source[2]}"
+ # http://git.savannah.gnu.org/cgit/guix.git/commit/?id=402bb3b
+ patch -Np1 < "${srcdir}/${source[3]}"
+}
+
build() {
bash_completion_dir="`pkg-config --variable=completionsdir bash-completion`"
cd ${srcdir}/${pkgname}-${pkgver}