summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorTing-Wei Lan2013-07-18 00:37:12 +0800
committerTing-Wei Lan2013-07-18 00:37:39 +0800
commita4fa677b9f828c8de58ddbd9ebc40b15208a6f09 (patch)
tree46ffa456e63335bc3deb8c70edc7f0a045eca1fe /PKGBUILD
parent464f6296b29292ad4b618cba8b76b277d26eba45 (diff)
downloadaur-a4fa677b9f828c8de58ddbd9ebc40b15208a6f09.tar.gz
guix: 0.2 -> 0.3
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD28
1 files changed, 12 insertions, 16 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 5375e22301d1..cf55ce337851 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,36 +2,32 @@
# Modified from guix-git 20130119 PKGBUILD
pkgname=guix
-pkgver=0.2
-pkgrel=2
+pkgver=0.3
+pkgrel=1
pkgdesc="GNU guix is a purely functional package manager"
arch=('x86_64' 'i686')
url="https://www.gnu.org/software/guix/"
license=('GPL')
depends=('guile>=2.0.5' 'sqlite>=3.6.19' 'bzip2' 'libgcrypt')
makedepends=()
-source=('ftp://alpha.gnu.org/gnu/guix/guix-0.2.tar.gz')
-md5sums=('4bdbbd736d0bbcb6cd7e28220c4ea1fe')
+source=("ftp://alpha.gnu.org/gnu/${pkgname}/${pkgname}-${pkgver}.tar.gz")
+md5sums=('1112e55273ce47cb89ccbdedb2d431f6')
build() {
current_arch="`uname -m`"
cd ${srcdir}/${pkgname}-${pkgver}
- ./configure --prefix=/usr --localstatedir=/var \
+ ./configure --prefix=/usr --localstatedir=/var \
--disable-rpath --with-system=${current_arch}-linux
- make
+ make
}
-# guix-0.2 cannot pass all tests because of some strange problems.
-# eg. build.sh or bipvm5958i36 not found
-
-#check() {
-# cd ${srcdir}/${pkgname}-${pkgver}
-# make -k -j1 check
-#}
+check() {
+ cd ${srcdir}/${pkgname}-${pkgver}
+ make -k -j1 chec
+}
package() {
cd ${srcdir}/${pkgname}-${pkgver}
- make DESTDIR="${pkgdir}" install
-# only required if enabling check()
-# chmod -R u+w test-tmp
+ make DESTDIR="${pkgdir}" install
+ chmod -R u+w test-tmp
}