summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorTing-Wei Lan2019-05-18 13:57:48 +0800
committerTing-Wei Lan2019-05-18 14:42:40 +0800
commitbe79cd02142edb309f67c1410a0c4a86726ae2e3 (patch)
tree22a82990a40c63931dc4660beee11969deff2a2e /PKGBUILD
parent8a1c10abc1cbbbdacdabbb5fe175d41367cefafa (diff)
downloadaur-be79cd02142edb309f67c1410a0c4a86726ae2e3.tar.gz
guix: 0.16.0 -> 1.0.0
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD98
1 files changed, 37 insertions, 61 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 33280c1076a9..7b99df121fee 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,7 +6,7 @@
# gpg --recv-keys 3CE464558A84FDC69DB40CFB090B11993D9AEBB5
pkgname=guix
-pkgver=0.16.0
+pkgver=1.0.0
pkgrel=1
pkgdesc="A purely functional package manager for the GNU system"
arch=('x86_64' 'i686' 'armv7h')
@@ -16,83 +16,59 @@ options=('!strip')
makedepends=(
'bash-completion'
'fish'
- 'guile-json'
+ 'guile-json1'
'guile-ssh>=0.10.2'
'help2man')
depends=(
- 'guile>=2.0.9'
+ 'guile>=2.2.4'
'guile-gcrypt'
'guile-git-lib'
'guile-sqlite3'
'sqlite>=3.6.19'
'bzip2'
- 'gnutls'
+ 'gnutls-guile'
'libgcrypt'
'zlib')
optdepends=(
'bash-completion: to enable bash programmable completion'
- 'guile-json: to import packages from cpan, gem, pypi'
+ 'guile-json1: to import packages from cpan, gem, pypi'
'guile-ssh: to offload builds to other machines')
source=(
- "https://alpha.gnu.org/gnu/${pkgname}/${pkgname}-${pkgver}.tar.gz"{,.sig}
- "aarch64-linux-20170217-guile-2.0.14.tar.xz::https://alpha.gnu.org/gnu/${pkgname}/bootstrap/aarch64-linux/20170217/guile-2.0.14.tar.xz"
- "aarch64-linux-20170217-guile-2.0.14.tar.xz.sig::https://alpha.gnu.org/gnu/${pkgname}/bootstrap/aarch64-linux/20170217/guile-2.0.14.tar.xz.sig"
- "armhf-linux-20150101-guile-2.0.11.tar.xz::https://alpha.gnu.org/gnu/${pkgname}/bootstrap/armhf-linux/20150101/guile-2.0.11.tar.xz"
- "armhf-linux-20150101-guile-2.0.11.tar.xz.sig::https://alpha.gnu.org/gnu/${pkgname}/bootstrap/armhf-linux/20150101/guile-2.0.11.tar.xz.sig"
- "i686-linux-20131110-guile-2.0.9.tar.xz::https://alpha.gnu.org/gnu/${pkgname}/bootstrap/i686-linux/20131110/guile-2.0.9.tar.xz"
-# "i686-linux-20131110-guile-2.0.9.tar.xz.sig::https://alpha.gnu.org/gnu/${pkgname}/bootstrap/i686-linux/20131110/guile-2.0.9.tar.xz.sig"
- "mips64el-linux-20131110-guile-2.0.9.tar.xz::https://alpha.gnu.org/gnu/${pkgname}/bootstrap/mips64el-linux/20131110/guile-2.0.9.tar.xz"
-# "mips64el-linux-20131110-guile-2.0.9.tar.xz.sig::https://alpha.gnu.org/gnu/${pkgname}/bootstrap/mips64el-linux/20131110/guile-2.0.9.tar.xz.sig"
- "x86_64-linux-20131110-guile-2.0.9.tar.xz::https://alpha.gnu.org/gnu/${pkgname}/bootstrap/x86_64-linux/20131110/guile-2.0.9.tar.xz"
-# "x86_64-linux-20131110-guile-2.0.9.tar.xz.sig::https://alpha.gnu.org/gnu/${pkgname}/bootstrap/x86_64-linux/20131110/guile-2.0.9.tar.xz.sig"
-)
+ "https://ftp.gnu.org/gnu/${pkgname}/${pkgname}-${pkgver}.tar.gz"{,.sig}
+ "${pkgname}-${pkgver}-docker-image.tmpl::https://git.savannah.gnu.org/cgit/guix.git/plain/gnu/system/examples/docker-image.tmpl?h=v${pkgver}"
+ 'guix-1.0.0-tests-gremlin.patch'
+ 'guix-1.0.0-tests-guix-pack-localstatedir.patch')
install="${pkgname}.install"
sha1sums=(
- '62f665dc02ea4c575f75b6728d6ec62875206846'
- 'ae4ded76633ff0d37c5297f457542cee2e6ee205'
+ 'fd64cd4347214a4e75d611696c9929cba8995323'
+ '42fef4a882b71b0413d33a6f9199a53cc92bba74'
'SKIP'
'SKIP'
- 'SKIP'
- 'SKIP'
- 'SKIP'
-# 'SKIP'
- 'SKIP'
-# 'SKIP'
- 'SKIP'
-# 'SKIP'
-)
+ 'SKIP')
sha256sums=(
'SKIP'
'SKIP'
- '3939909f24dcb955621aa7f81ecde6844bea8a083969c2d275c55699af123ebe'
- 'bfceb1a0cb92c9182e5bc2bfe9e728078df0f5f86e6580820ead845d7f11f3c5'
- 'e551d05d4d385d6706ab8d574856a087758294dc90ab4c06e70a157a685e23d6'
- '4ceb3b490e2eed1631ec204d68ebf2a91806f6d1c438fc3a8d744b3f0351633d'
- 'b757cd46bf13ecac83fb8e955fb50096ac2d17bb610ca8eb816f29302a00a846'
-# '5c710ad8efa927711347cb585ceec25d99c3b3065955060275076be55f46f228'
- '994680f0001346864aa2c2cc5110f380ee7518dcd701c614291682b8e948f73b'
-# 'd22c325e7d64b805679cc449b8865f7ac7629b83c71a6ae9812541408bac1952'
- '037b103522a2d0d7d69c7ffd8de683dfe5bb4b59c1fafd70b4ffd397fd2f57f0'
-# '50ec32f47dd659583d7ee633b8d6d4180b413c3680b1628ab6346241ac2c2b46'
-)
+ 'f0567476a202c1c3bc3eacf991f3b5f5af030ed165a1846d045a9a375f4851ba'
+ '6dd16cbf6b8d03e866e8dcc29a9b3ae689438de7041e05cb303a7585634ae80a'
+ '2038b2e2282ce29b837701688d86339ccdf1df6f7d842c45f663046489d47415')
validpgpkeys=('3CE464558A84FDC69DB40CFB090B11993D9AEBB5')
-noextract=(
- 'aarch64-linux-20170217-guile-2.0.14.tar.xz'
- 'armhf-linux-20150101-guile-2.0.11.tar.xz'
- 'i686-linux-20131110-guile-2.0.9.tar.xz'
- 'mips64el-linux-20131110-guile-2.0.9.tar.xz'
- 'x86_64-linux-20131110-guile-2.0.9.tar.xz')
-_noextract_dest_map=(
- 'gnu/packages/bootstrap/aarch64-linux/guile-2.0.14.tar.xz'
- 'gnu/packages/bootstrap/armhf-linux/guile-2.0.11.tar.xz'
- 'gnu/packages/bootstrap/i686-linux/guile-2.0.9.tar.xz'
- 'gnu/packages/bootstrap/mips64el-linux/guile-2.0.9.tar.xz'
- 'gnu/packages/bootstrap/x86_64-linux/guile-2.0.9.tar.xz')
prepare() {
cd "${srcdir}/${pkgname}-${pkgver}"
- for index in $(seq 0 $((${#noextract[@]} - 1))); do
- cp "${srcdir}/${noextract[${index}]}" "${_noextract_dest_map[${index}]}"
+ # Obtain the file from the git repository and put it into the source tree.
+ # It is required by the test tests/guix-system.sh.
+ # https://debbugs.gnu.org/35774
+ cp "${srcdir}/${source[2]%%::*}" gnu/system/examples/docker-image.tmpl
+ # Apply patches to avoid unexpected test failure.
+ # https://debbugs.gnu.org/35775
+ # https://debbugs.gnu.org/35776
+ local source_file
+ for source_file in "${source[@]}"; do
+ case "${source_file}" in
+ *.patch)
+ patch -p1 < "${srcdir}/${source_file}"
+ ;;
+ esac
done
}
@@ -104,23 +80,23 @@ build() {
--libexecdir="/usr/lib/${pkgname}" --localstatedir=/var \
--with-bash-completion-dir="${bash_completion_dir}" \
--with-fish-completion-dir="${fish_completion_dir}" \
- --disable-rpath
+ --disable-rpath \
+ ac_cv_guix_test_root="$(pwd)/t"
make
}
check() {
- # FIXME: There are too many failed tests and upstream developers haven't
- # made any response. All tests are temporarily skipped for now.
- # https://debbugs.gnu.org/32098
- return 0
-
cd "${srcdir}/${pkgname}-${pkgver}"
# Check whether the current working directory is too long
local cwd_str="$(pwd)"
local cwd_len="${#cwd_str}"
- if [ "${cwd_len}" -gt 46 ]; then
+ # The test tests/gexp.scm fails when the path is longer than 29 bytes
+ # because of the length limit on the shebang line. Since we have increased
+ # the limit by 7 by renaming test-tmp to t with ac_cv_guix_test_root cache
+ # variable, the limit we use here is 36 bytes.
+ if [ "${cwd_len}" -gt 36 ]; then
error "${cwd_str} is too long."
- error "The working directory cannot be longer than 46 bytes."
+ error "The working directory cannot be longer than 36 bytes."
false
fi
# Make sure we have a valid shell accepting -c option