summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorTing-Wei Lan2015-07-24 12:39:51 +0800
committerTing-Wei Lan2015-07-24 14:37:09 +0800
commitc5e146df37695982f0aedef8a2723b4a1e7f19ce (patch)
tree5e3965495e5217d6b18343530f24ec2a91e0482d /PKGBUILD
parent31b92962619ebdaacb861f10c415085ec6f84930 (diff)
downloadaur-c5e146df37695982f0aedef8a2723b4a1e7f19ce.tar.gz
guix: Remove the systemd service file written by me
Upstream already provides a better systemd service file.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD11
1 files changed, 3 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 3fc7d7f33d8c..799532109e16 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,7 +7,7 @@
pkgname=guix
pkgver=0.8.3
-pkgrel=1
+pkgrel=2
pkgdesc="GNU guix is a purely functional package manager"
arch=('x86_64' 'i686')
url="https://www.gnu.org/software/guix/"
@@ -24,12 +24,10 @@ optdepends=(
'bash-completion: to enable bash programmable completion'
'emacs: to enable Emacs Interface')
source=(
- "ftp://alpha.gnu.org/gnu/${pkgname}/${pkgname}-${pkgver}.tar.gz"{,.sig}
- "guix.service")
+ "ftp://alpha.gnu.org/gnu/${pkgname}/${pkgname}-${pkgver}.tar.gz"{,.sig})
install="${pkgname}.install"
sha256sums=('dfea48f13e6584db812c24746467eb21cb0553a2f5860e1fe40d4e06e4b4c092'
- '411b3b850191f1fc701e9a2178aa02a403c44baa59b58a6ef9c18237a10fd049'
- 'd0a014de859c4f5d6f760be84991b88f4855ead933368f3ab815a1deabc361ce')
+ '411b3b850191f1fc701e9a2178aa02a403c44baa59b58a6ef9c18237a10fd049')
validpgpkeys=('3CE464558A84FDC69DB40CFB090B11993D9AEBB5')
build() {
@@ -51,7 +49,4 @@ check() {
package() {
cd ${srcdir}/${pkgname}-${pkgver}
make DESTDIR="${pkgdir}" install
- mkdir -p ${pkgdir}/usr/lib/systemd/system
- install -m 644 "${srcdir}/guix.service" \
- ${pkgdir}/usr/lib/systemd/system/guix.service
}