summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorTing-Wei Lan2020-04-29 18:28:38 +0800
committerTing-Wei Lan2020-04-29 18:28:38 +0800
commite0b920d655689e4105657ba3b6ced633af106588 (patch)
tree332e969f6875e50bd7e84e9323137a965447e7f2 /PKGBUILD
parent47b093f77c085beb6c90d13d6d945cc13b20c6a3 (diff)
downloadaur-e0b920d655689e4105657ba3b6ced633af106588.tar.gz
guix: 1.0.1+3489+g0ed97e6980 -> 1.1.0
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD51
1 files changed, 11 insertions, 40 deletions
diff --git a/PKGBUILD b/PKGBUILD
index b6ed40840328..82b5788e4194 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,7 +6,7 @@
# gpg --recv-keys 3CE464558A84FDC69DB40CFB090B11993D9AEBB5
pkgname=guix
-pkgver=1.0.1+3489+g0ed97e6980
+pkgver=1.1.0
pkgrel=1
pkgdesc="A purely functional package manager for the GNU system"
arch=('x86_64' 'i686' 'armv7h')
@@ -16,7 +16,6 @@ options=('!strip')
makedepends=(
'bash-completion'
'fish'
- 'git'
'guile-json>=3'
'guile-ssh>=0.10.2'
'help2man'
@@ -36,26 +35,18 @@ optdepends=(
'bash-completion: to enable bash programmable completion'
'guile-json: to import packages from cpan, gem, pypi'
'guile-ssh: to offload builds to other machines')
-_commit=0ed97e69805253656df929a6ad678016aa81f08a
source=(
- "git+https://git.savannah.gnu.org/git/${pkgname}.git#commit=${_commit}")
+ "https://ftp.gnu.org/gnu/${pkgname}/${pkgname}-${pkgver}.tar.gz"{,.sig})
install="${pkgname}.install"
-sha1sums=(
- 'SKIP')
sha256sums=(
- 'SKIP')
+ '5c59106ff4ac497c6097686834b0c914109cf5e44eb6b94ebce818923043640f'
+ '0416a733ba9b4410897d744a24388a43ba11bd8c427c7d08e649c8875119333d')
validpgpkeys=('3CE464558A84FDC69DB40CFB090B11993D9AEBB5')
-pkgver() {
- cd "${srcdir}/${pkgname}"
- git describe --exclude 'bootstrap-*' --tags | sed -e 's/-/+/g' -e 's/^v//g'
-}
-
build() {
local bash_completion_dir="$(pkg-config --variable=completionsdir bash-completion)"
local fish_completion_dir="$(pkg-config --variable=completionsdir fish)"
- cd "${srcdir}/${pkgname}"
- ./bootstrap
+ cd "${srcdir}/${pkgname}-${pkgver}"
./configure --prefix=/usr --sbindir=/usr/bin --sysconfdir=/etc \
--libexecdir=/usr/lib --localstatedir=/var \
--with-bash-completion-dir="${bash_completion_dir}" \
@@ -66,7 +57,7 @@ build() {
}
check() {
- cd "${srcdir}/${pkgname}"
+ cd "${srcdir}/${pkgname}-${pkgver}"
# Check whether the current working directory is too long
local cwd_str="$(pwd)"
local cwd_len="${#cwd_str}"
@@ -84,10 +75,14 @@ check() {
}
package() {
- cd "${srcdir}/${pkgname}"
+ cd "${srcdir}/${pkgname}-${pkgver}"
make DESTDIR="${pkgdir}" install
# Remove unused upstart service files
rm -r "${pkgdir}/usr/lib/upstart"
+ # Remove unused sysvinit service files
+ rm -r "${pkgdir}/etc/init.d"
+ # Remove the empty directory left by sysvinit service files as well
+ rmdir "${pkgdir}/etc"
# Rename systemd service files provided by upstream because they are not
# usable without previous guix installation
local system_unit_dir="${pkgdir}/usr/lib/systemd/system"
@@ -125,28 +120,4 @@ package() {
cd "${pkgdir}/usr/bin"
tidy_strip
eval 'options=("!strip")'
- # Make sure bootstrap binaries are not modified
- cd "${pkgdir}/usr/share/guile/site/2.2/gnu/packages/bootstrap"
- cat << EOF | sha256sum -c
-e3bf6ffe357eebcc28221ffdbb5b00b4ed1237cb101aba4b1b8119b08c732387 aarch64-linux/bash
-444c2af9fefd11d4fc20ee9281fa2c46cbe3cfb3df89cc30bcd50d20cdb6d6c0 aarch64-linux/mkdir
-05273f978a072269193e3a09371c23d6d149f6d807f8e413a4f79aa5a1bb6f25 aarch64-linux/tar
-48e9baa8a6c2527a5b4ecb8f0ac87767e2b055979256acab2a3dbff4f6171637 aarch64-linux/xz
-2ad82bb9ee6e77eaff284222e1d43a2829b5a1e2bcf158b08564a26da48e0045 armhf-linux/bash
-a19e386b31ebc8a46b5f934c11bca86e28f8aa997272a5fcd052b52d5019f790 armhf-linux/mkdir
-da56be0b332fac3880b151abe60c1eeb2649cd192379b18658b1d872f7aa53e8 armhf-linux/tar
-6507d04d55210e3a8cdc2e5758d79a4b0da3cb53bb142f60a78788af7b915ab1 armhf-linux/xz
-ed059a9ae964d538605c923c4e73128bd5ca912994709b3fe2d71d061751e8c5 i686-linux/bash
-b369264bda7bbb98d1acf0bf53ebc9077e82f48b190f3956fa23cb73d6e99f92 i686-linux/mkdir
-9f7e79e52aa369fc9ed69359e503d4f8179117842df8261fc0cae5629cc896cb i686-linux/tar
-d23173dfe66c41e1c8d8eef905d14d1f39aaa52c9d70621f366c275e9139b415 i686-linux/xz
-213cfb8794ffdf4a71cb321a89987ee61704edcec5d1203912575f0a626a239c mips64el-linux/bash
-d436070fde044366d72d7e59d8d12b1ba72b32d7b0f13e409b61118bdc8254c8 mips64el-linux/mkdir
-d27fcb52f9b4a42fafdae3164fffd200f52e04d142574dcf06212dbf7701cbb8 mips64el-linux/tar
-107eac7523b0148d18f461d81bec9d0db6154d6c61e4caf3a4cdb43a9a6afb3c mips64el-linux/xz
-265d2f633a5ab35747fc4836b5e3ca32bf56ad44cc24f3bd358f1ff6cf0779a5 x86_64-linux/bash
-50689abdf2d5374e17ea8c51801f04f7590ad604af33a12a940cc11d137a4a2f x86_64-linux/mkdir
-16440b4495a2ff9c6aa50c05a8c9066e1004a5990b75aa891f08cdf8753c8689 x86_64-linux/tar
-930ad7e88ca0b2275dc459b24aea912fadd5b7c9e95be06788d4b61efc7ef470 x86_64-linux/xz
-EOF
}