summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorChristoph Haag2024-02-26 13:20:12 +0100
committerChristoph Haag2024-02-26 13:20:39 +0100
commit3768f2e2edab30282ba731d64c6b5306cc32697e (patch)
tree81d4348875ab0ae01dbfe10fb3bf1db34b7eb9bf /PKGBUILD
parent56c4167715cc0e9c4954571ed199e067ac4823f6 (diff)
downloadaur-3768f2e2edab30282ba731d64c6b5306cc32697e.tar.gz
cleanup namcap warnings
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD13
1 files changed, 6 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index ca5bf011be4b..1d8b1c40b036 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,12 +2,13 @@
_realname='gulkan'
pkgname="$_realname-git"
-pkgver=0.16.0.442.54e80d2
+pkgver=0.16.0.r445.55721c9
pkgrel=1
pkgdesc='A GLib library for Vulkan abstraction.'
arch=('i686' 'x86_64')
url='https://gitlab.freedesktop.org/xrdesktop/gulkan'
-depends=('gdk-pixbuf2' 'vulkan-icd-loader' 'graphene' 'cairo' 'shaderc' 'json-glib' 'libxkbcommon' 'wayland' 'xcb-util-keysyms' 'libdrm' 'wayland-protocols' 'glfw')
+depends=('glibc' 'glib2' 'gdk-pixbuf2' 'vulkan-icd-loader' 'graphene' 'cairo' 'shaderc' 'json-glib' 'libxkbcommon' 'wayland' 'libxcb' 'xcb-util-keysyms')
+# Dependencies only used for examples: 'libdrm' 'wayland-protocols' 'glfw')
provides=("$_realname="$pkgver)
conflicts=("$_realname")
makedepends=('meson' 'git' 'vulkan-headers' 'gtk-doc')
@@ -22,15 +23,13 @@ ver() {
}
pkgver() {
- cd $_realname
- hash=$(git log --pretty=format:'%h' -n 1)
- revision=$(git rev-list --count HEAD)
- echo $(ver).$revision.$hash
+ cd "$_realname"
+ printf "$(ver).r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short=7 HEAD)"
}
build() {
rm -rf build
- arch-meson $_realname build --libdir=lib --buildtype release -Dapi_doc=true
+ arch-meson "$_realname" build --libdir=lib --buildtype release -Dapi_doc=true
ninja -C build
}