summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorBernhard Landauer2016-11-29 19:44:46 +0100
committerBernhard Landauer2016-11-29 19:44:46 +0100
commit4816d6cb0b0ffe921a008bec98010c57b49fd34e (patch)
tree72257e6f02cd9a8779132c8736d0b7d7efcf6a56 /PKGBUILD
parent7035082710458c7a1762019ab65b46cf70c35c36 (diff)
downloadaur-guvcview-qt5-git.tar.gz
update to 2.0.4.r33
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD10
1 files changed, 8 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index aa512c607cfb..8e0ba2f9d520 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Maintainer: Tobias Frilling <tobias@frilling-online.de>
pkgname=guvcview-qt5-git
-pkgver=2.0.4.r16.g81a05b1
+pkgver=2.0.4.r33.gf618a10
pkgrel=1
pkgdesc="Video viewer and capturer for the linux uvc driver, Qt5-version"
arch=('i686' 'x86_64')
@@ -14,6 +14,7 @@ depends=('ffmpeg'
'libusb'
'portaudio'
'qt5-base'
+ 'sfml'
'sdl2')
makedepends=('git'
'intltool'
@@ -33,8 +34,13 @@ build() {
cd "$srcdir/$pkgname"
export CPPFLAGS+=" -O2 "
+ export CXXFLAGS="-std=c++11"
./bootstrap.sh --prefix=/usr
- ./configure --disable-gtk3 --enable-qt5 --disable-debian-menu --prefix=/usr
+ ./configure --prefix=/usr \
+ --disable-gtk3 \
+ --enable-qt5 \
+ --disable-debian-menu \
+ --enable-sfml
make
}