summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorFernando Fernandez2019-10-02 20:02:11 -0300
committerFernando Fernandez2019-10-02 20:02:11 -0300
commitcc4879ec102c60c6ed5ac4a19c1ed97a5b8ca086 (patch)
tree28f682800a6440f2cc3200d3c283fe670889019a /PKGBUILD
parent0b70d4c08dd6241916dea21be794264b6e42fbdc (diff)
downloadaur-cc4879ec102c60c6ed5ac4a19c1ed97a5b8ca086.tar.gz
fix valadoc icon dir
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD20
1 files changed, 15 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index fc449d79217b..baff3621e726 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
# Maintainer: Fernando Fernández <fernando@softwareperonista.com.ar>
_pkgname=gvls
pkgname=${_pkgname}-git
-pkgver=0.10.2+42+g065a4bc
-pkgrel=2
+pkgver=0.10.2+65+gb8cfdb7
+pkgrel=1
pkgdesc='GNOME Vala Language Server'
arch=(i686 x86_64)
url='https://gitlab.gnome.org/esodan/gvls'
@@ -13,16 +13,26 @@ depends=(vala libgee libpeas gtksourceview3 gtksourceview4 jsonrpc-glib)
makedepends=(git meson)
optdepends=()
groups=()
-source=("git+https://gitlab.gnome.org/esodan/gvls.git")
-sha256sums=('SKIP')
+source=("git+https://gitlab.gnome.org/esodan/gvls.git"
+ "fix-valadoc-icon-dir.patch")
+sha256sums=('SKIP'
+ 'f56f8cc2b42ef491f6f2088b313e6d34d7bfe307b81990f842d2f6e8df829196')
pkgver() {
cd ${_pkgname}
+
git describe --tags | sed 's/^gvls-//;s/_/./g;s/-/+/g'
}
+prepare() {
+ cd ${_pkgname}
+
+ patch -Np1 -i ../fix-valadoc-icon-dir.patch
+}
+
build() {
- arch-meson ${_pkgname} build
+ arch-meson ${_pkgname} build \
+ -Ddisable-valadocs=false
ninja -C build
}