summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorcrimist2023-09-29 10:29:47 -0700
committercrimist2023-09-29 10:29:47 -0700
commit145d7932f8066921209e735297806875be88b2d2 (patch)
treeedaefdce367958bbd08568ef4807e269487733d0 /PKGBUILD
parent3e8d160df10a1e7e5a334e7f4bd8bce9fff2fa3f (diff)
downloadaur-145d7932f8066921209e735297806875be88b2d2.tar.gz
Update to v0.15.6, add gitignore
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD26
1 files changed, 10 insertions, 16 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 87bf70c64649..b70bb7a15b5d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,30 +1,24 @@
-# Maintainer: Sophie Tauchert <sophie@999eagle.moe>
+# Maintainer: crimist <aur at crim dot ist>
+# Contributor: Sophie Tauchert <sophie@999eagle.moe>
pkgname=gwe
-pkgver=0.15.5
-pkgrel=3
+pkgver=0.15.6
+pkgrel=1
pkgdesc="A system utility for controlling NVIDIA GPUs"
arch=('any')
url="https://gitlab.com/leinardi/gwe"
license=('GPL3')
-depends=('gobject-introspection' 'libdazzle' 'libappindicator-gtk3' 'libnotify' 'python' 'python-cairo' 'python-gobject' 'python-injector' 'python-matplotlib' 'python-peewee' 'python-py3nvml' 'python-requests' 'python-rx' 'python-pyxdg' 'python-xlib')
+depends=('gobject-introspection' 'libdazzle' 'libnotify' 'python' 'python-cairo' 'python-injector' 'python-matplotlib' 'python-peewee' 'python-py3nvml' 'python-gobject' 'python-xlib' 'python-pyxdg' 'python-requests' 'python-reactivex')
makedepends=('meson' 'appstream-glib')
-provides=()
+optdepends=('libappindicator-gtk3: tray support')
source=("https://gitlab.com/leinardi/gwe/-/archive/$pkgver/$pkgname-$pkgver.tar.gz")
-sha256sums=('67c30c735b6160c2f4af61ce353108dc9709b6c850ce8bc21d2d2a506dfa3b70')
+sha256sums=('60c19431ab20cc785dfd6547fccd225d3ff317b5bfd57961441bf8212cc8247c')
build() {
- if [[ -d "$srcdir/build" ]]; then
- rm -rf "$srcdir/build"
- fi
- meson --prefix /usr --buildtype=plain "$pkgname-$pkgver" build
- ninja -C build
-}
-
-check() {
- ninja -C build test
+ arch-meson $pkgname-$pkgver build
+ meson compile -C build
}
package() {
- DESTDIR="$pkgdir" ninja -C build install
+ meson install -C build --destdir "$pkgdir"
}