summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorweiliang15032020-10-25 20:16:28 +0800
committerweiliang15032020-10-25 20:16:28 +0800
commit841746cf34e7b1f091cc5c35265bd7bc1307d396 (patch)
tree44a81a87c6b6c0e64a616c728483b6a196cf3419 /PKGBUILD
downloadaur-841746cf34e7b1f091cc5c35265bd7bc1307d396.tar.gz
gwm's first package
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD24
1 files changed, 24 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..83a350d70230
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Liang Wei <weiliang1503@yandex.com>
+pkgname=gwm
+pkgver=0.7.4
+pkgrel=1
+epoch=
+pkgdesc="A modern tilling windows manager for X11"
+arch=('x86_64')
+url="https://sourceforge.net/projects/gsmwm/"
+license=('GPL')
+depends=('bash' 'libx11')
+makedepends=('git')
+source=("$srcdir/$pkgname-$pkgver::git://git.code.sf.net/p/gsmwm/code")
+noextract=("${source[@]##*/}")
+md5sums=('SKIP')
+
+build() {
+ cd "$pkgname-$pkgver"
+ make
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+ make prefix="$pkgdir/usr/" install
+}