summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorØystein Sture2023-10-09 21:43:58 +0200
committerØystein Sture2023-10-09 21:43:58 +0200
commit08be910e6429170713e0b7789592f7459543e07d (patch)
treea24de1c5738a26316bceef59f077bc95ec4d56ef /PKGBUILD
downloadaur-08be910e6429170713e0b7789592f7459543e07d.tar.gz
Initial gz-harmonic commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD48
1 files changed, 48 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7748e3c6cfb0
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,48 @@
+# Maintainer: oysstu <oysstu at gmail dot com>
+
+pkgname=gz-physics7
+pkgver=7.0.0
+pkgrel=1
+_pkgmaj=${pkgver%%.*}
+_pkgbase=${pkgname::-${#_pkgmaj}}
+pkgdesc="Abstract physics interface designed to support simulation and rapid development of robot applications."
+arch=('any')
+url="https://github.com/gazebosim/${_pkgbase}"
+license=('Apache')
+depends=(
+ 'eigen'
+ 'gz-common=5'
+ 'gz-math=7'
+ 'gz-plugin=2'
+ 'gz-utils=2'
+ 'sdformat=14'
+ 'bullet'
+ 'libdart'
+ )
+makedepends=(
+ 'cmake'
+ 'doxygen'
+ 'gz-cmake=3'
+ )
+optdepends=(
+ #'libdart: DARTsim physics plugin'
+ #'bullet: bullet physics plugin'
+)
+provides=("${_pkgbase}=${_pkgmaj}")
+source=("https://github.com/gazebosim/${_pkgbase}/archive/${pkgname}_${pkgver}.tar.gz")
+sha256sums=('d352b68bec5d2e28cb20237d2cb68917e4acfe122e6df0dc059ed436d65fd270')
+
+_build_dir="${_pkgbase}-${pkgname}_${pkgver}/build"
+
+build() {
+ mkdir -p "$srcdir/$_build_dir" && cd $_
+ cmake .. -DCMAKE_BUILD_TYPE='None' \
+ -DCMAKE_INSTALL_PREFIX='/usr' \
+ -DBUILD_TESTING=OFF \
+ -Wno-dev
+ cmake --build .
+}
+
+package() {
+ DESTDIR="$pkgdir" cmake --install "$srcdir/$_build_dir"
+}