summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAlexander Dunlap2021-10-09 10:16:00 -0400
committerAlexander Dunlap2021-10-09 10:16:00 -0400
commita1b39d9fe5c060f270e84a810e969e6baea709b3 (patch)
tree605f6dbaf3c8bfadfe1de94b5a707b978268e1ef /PKGBUILD
parentd3b88655cc81de6c284bef8beb87b816b4eb2b18 (diff)
downloadaur-a1b39d9fe5c060f270e84a810e969e6baea709b3.tar.gz
Updating PKGBUILD to avoid compile failures with -Werror=format-security; thanks to Angel de Vicente for the patch
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD8
1 files changed, 5 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 6572304896f1..fc21a359e912 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Alexander Dunlap <alexander dot dunlap at gmail dot com>
pkgname=h4h5tools
pkgver=2.2.5
-pkgrel=1
+pkgrel=2
epoch=
pkgdesc="Tools for converting between HDF4 and HDF5 formats"
arch=('x86_64')
@@ -19,9 +19,10 @@ backup=()
options=()
install=
changelog=
-source=("https://support.hdfgroup.org/ftp/HDF5/releases/h4toh5/h4toh5-$pkgver/src/$pkgname-$pkgver.tar.gz" "h4h5tools-configure-lm.patch")
+source=("https://support.hdfgroup.org/ftp/HDF5/releases/h4toh5/h4toh5-$pkgver/src/$pkgname-$pkgver.tar.gz" "h4h5tools-configure-lm.patch" "h4h5tools-format-security-fix.patch")
noextract=()
-sha256sums=("79f6505c1df3ad0c2cc1a19b9b433b5d955dfd7d2dffefc080d89fdde01fd6f2" "ac04b58e9d84a9ca158ad58c4c83fe43d2bddecf685061c9e78ad07bd4ac6a83")
+sha256sums=("79f6505c1df3ad0c2cc1a19b9b433b5d955dfd7d2dffefc080d89fdde01fd6f2" "ac04b58e9d84a9ca158ad58c4c83fe43d2bddecf685061c9e78ad07bd4ac6a83"
+"04d4e7a9458f887187de2e8816eea238d9e49eae6f9e2b70524a69a510a48aeb")
validpgpkeys=()
prepare() {
@@ -31,6 +32,7 @@ prepare() {
build() {
cd "$pkgname-$pkgver"
patch -p0 -i "$srcdir/h4h5tools-configure-lm.patch"
+ patch -p1 -i "$srcdir/h4h5tools-format-security-fix.patch"
autoreconf -i
CC="/opt/hdf4/bin/h4cc" ./configure --with-hdf5=/usr --with-hdfeos2=/usr --prefix=/usr
make