summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorEric Berquist2022-06-28 10:13:24 -0400
committerEric Berquist2022-06-28 10:13:24 -0400
commit3d73ead30c8e79bdffe3b9c4367889a9e6de040b (patch)
tree0fd25ca6337df12061a5345ed03ad4c863eb270d /PKGBUILD
parent00fb58d3164f075b09f5cdd45e3c87d7a6745591 (diff)
downloadaur-h5cpp.tar.gz
Version bump: 0.4.1 -> 0.5.1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD11
1 files changed, 8 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 062f0d703361..c1ebc043dc7f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Contributor: Lorenz Steinert <lorenz@steinerts.de>
pkgname=h5cpp
-pkgver=0.4.1
+pkgver=0.5.1
pkgrel=1
pkgdesc="h5cpp is a C++ wrapper for HDF5s C-API."
arch=('i686' 'x86_64' 'armv6h' 'armv7h')
@@ -12,14 +12,19 @@ depends=('boost-libs' 'hdf5')
optdepends=()
makedepends=('cmake' 'boost')
source=("https://github.com/ess-dmsc/$pkgname/archive/v$pkgver.tar.gz")
-sha256sums=('dd0833619fc9ef615829cfcbfaeca0694f27b3c1ca573633ee103e4c7aa92ebb')
+sha256sums=('8fcab57ffbc2d799fe315875cd8fcf67e8b059cccc441ea45a001c03f6a9fd25')
build() {
cd $srcdir/$pkgname-$pkgver
mkdir -p build
cd build
- cmake -DCONAN=DISABLE -DCMAKE_INSTALL_PREFIX=/usr ..
+
+ cmake \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DH5CPP_CONAN=DISABLE \
+ ..
+
make
}